[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#261745: marked as done ([hendrik@pooq.com: Re: Did that. Now no net.])

Your message dated Wed, 08 Sep 2010 03:58:42 +0000
with message-id <E1OtBo2-00069Y-7Y@ravel.debian.org>
and subject line Closing old installation report #261745
has caused the Debian Bug report #261745,
regarding [hendrik@pooq.com: Re: Did that.  Now no net.]
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

261745: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=261745
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: <Fill in date and from where you got the image>
uname -a: <The result of running uname -a on a shell prompt>
Date: <Date and time of the install>
Method: <How did you install?  What did you boot off?  If network
      install, from where?  Proxied?>

Machine: <Description of machine (eg, IBM Thinkpad R32)>
Processor: Athlon maybe 1600?
Memory: 1 Gigabyte
Root Device: <IDE?  SCSI?  Name of device?> /dev/hda2, 8.5Gig
Root Size/partition table: <Feel free to paste the full partition
      table, with notes on which partitions are mounted where.>
Output of lspci:

pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:0d.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
0000:00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:0f.0 RAID bus controller: Promise Technology, Inc. 20265 (rev 02)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc R200 BB [Radeon All in Wonder 8500DV]

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

I tried to install sarge on /dev/hda3, shile preserving an existing
woody on /dev/hda4, just in case...  /dev/hda1 is a Windows ME system,
ans /dev/hda2 is an extended partition with lots of secondary partitions,
mostly for Windows, but one swap partition.

I downloaded the beta-4 iso and burned a CD from it.  I booted that CD
using the SBM disk that I think I once got from www.bootdisk.com.
This got me into the debian net-installer, and installed onto /dev/hda3.
/dev/hda4 still contains my woody system, which still works
perfectly.  My Windows ME partition still works as imperfectly as ever.

But the new and very minimal sarge can't access the net.  Pings don't seem
to get as far as the ethernet card.

Here's the routing table:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   U     0      0        0 eth0         UG    0      0        0 eth0

It's identical to the routing table on the woody system.

Here's the output from ifconfig:

eth0      Link encap:Ethernet  HWaddr 00:0A:E6:55:93:CD  
          inet addr:  Bcast:  Mask:
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18 Base address:0xb400 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:6 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:657 (657.0 b)  TX bytes:657 (657.0 b)

It's the same as the one from woody, except that
woody gives me nonzero packet counts.
etho has interrupt: 18 instead of interrupt:5  Aren't these
dynamically assigned during boot, though?

Pinging to and work fine.  Both of them are,
of course, IP numbers for the machine doing the pinging, so it doesn't
need to get to the ethernet card.

What should I do to diagnose the problem.

Did the installer, which seemed pretty straightforward, miss some
essential component?  I did the default (I presume nonexpert 2.4 kernel)
installation.  Did I do something unobviously wrong?
Needless to say, I can't access any of the Debian archives
to get any further.

I might add that my /etc/resolv.conf file contained no nameserver IP numbers.
I had to hand-edit them in.  Not that they would have been useful
without net access.  But this might indicate something about which
installation step failed or was inadvertently skipped.  Thanks for
including nano in the base install -- I can never remember how to use vi.

I repeated the entire process, in case I screwed wverything up by a typo,
but got no further.  By pressing alt-F2, altF3, etc., I was treated to the following message (hand-copied):

syslog.info klogd: NETDEV WATCHDOG: eth0: transmit timed out
syslog.debug: klogd: eth0. Tx queue start emtry 4 dirty entry 0
syslog.debug: klogd: eth0. Tx descriptor 0 is 00002000
syslog.debug: klogd: eth0. Tx descriptor 1 is 00002000
syslog.debug: klogd: eth0. Tx descriptor 2 is 00002000
syslog.debug: klogd: eth0. Tx descriptor 3 is 00002000
syslog.info klogd: eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

These things repeated over and over and over.

After the reboot, where you enter the timezone data snd choose the
mirrod to for the rest of the net installation, the nice screen kept
getting clobbered with the messages:

NETDEV WATCHDOG: eth0: transmit timed out
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1

It looks to me as if it has recognized my ethernet card, but is not
driving it correctly.

 -- hendrik@pooq.com

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: