[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#260763: marked as done (Installed on a PC with root and boot on a logical volume)

Your message dated Wed, 08 Sep 2010 03:58:41 +0000
with message-id <E1OtBo1-00068S-Nb@ravel.debian.org>
and subject line Closing old installation report #260763
has caused the Debian Bug report #260763,
regarding Installed on a PC with root and boot on a logical volume
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

260763: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=260763
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/daily/i386/20040719/sarge-i386-businesscard.iso

uname -a: Linux rakuen 2.6.7-1-686 #1 Thu Jul 8 05:36:53 EDT 2004 i686 GNU/Linux

Date: 19 July 2004

Method:	I installed via network using a cable modem connection
	behind a simple firewall. DHCP was available.

Machine: Home Built P4 with Intel i850 based motherboard

Processor: P4 based 1.7 celeron

Memory: 512MB Rambus

Root Device: SCSI drive root device /dev/rakuen/root

Root Size/partition table:
This installation used only LVM2 to manage system volumes. Doing this
required using lilo as the boot loader. To the best of my knowledge grub
doesn't support have the /boot files in a logical volume. Whereas lilo
supports this without issue. The outputs of pvscan, vgscan, and lvscan are
below. The pvcreate program was run manually on /dev/sda. There is no PC
partition table.
	--| output of pvscan |--
  PV /dev/sda   VG rakuen   lvm2 [16.96 GB / 0    free]
  Total: 1 [16.96 GB] / in use: 1 [16.96 GB] / in no VG: 0 [0   ]
	--| output of vgscan |--
  Reading all physical volumes.  This may take a while...
  Found volume group "rakuen" using metadata type lvm2
	--| output of lvscan |--
  ACTIVE            '/dev/rakuen/root' [4.96 GB] inherit
  ACTIVE            '/dev/rakuen/swap' [2.00 GB] inherit
  ACTIVE            '/dev/rakuen/home' [10.00 GB] inherit

Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 82850 850 (Tehama) Chipset Host Bridge (MCH) (rev 04)
0000:00:01.0 PCI bridge: Intel Corp. 82850 850 (Tehama) Chipset AGP Bridge (rev 04)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 04)
0000:00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 04)
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 04)
0000:00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 04)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 04)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QM [Radeon 9100]
0000:02:01.0 USB Controller: NEC Corporation USB (rev 41)
0000:02:01.1 USB Controller: NEC Corporation USB (rev 41)
0000:02:01.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
0000:02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
0000:02:0b.0 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 03)
0000:02:0b.1 SCSI storage controller: Adaptec AHA-2940U/UW / AHA-39xx / AIC-7895 (rev 03)

Base System Installation Checklist:
Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

DI correctly configured my network using DHCP but the system failed to keep
that configuration after reboot. I had to manually create the 'interfaces'
file in /etc/network to get my network connection up.

As noted above this installation used only LVM2 to manage system volumes.
There is no PC based partition table on the drive. To accomplish this, when
prompted to configure the partitions I switched to VT 2 and used the
console to run "pvcreate /dev/sda". I then tried to use the gui to create a
volume group on the drive. The gui did not recognize the physical volume I
had just created on the drive. So I returned to VT 2 to run
"vgcreate rakuen /dev/sda". 'rakuen' is the name of the system so I used it
for the volume group as well. If I recall correctly I still had problems in
the gui trying to create the logical volumes untill I ran "vgscan" on VT 2.
Once I did that the gui allowed me to create the logical volumes and format
and mount them. I think the wording was a little odd during that part but
it was functional.

Once this was completed the rest of the install went smoothly untill grub
tried to install. DI automatically started installing grub. There was no
prompt before it was being downloaded. This made some trouble for me since I
had to use lilo and not grub. Apparently once the gui has installed the grub
package it won't remove it and lilo can't install as a result. I believe
that I ended up going to VT 2 and chrooting into the new install to remove
grub and install lilo. If we're going to offer to install lilo in the menu
then we shouldn't automatically start installing grub. Or we should offer an
obvious means of removing it if a user changes their mind.

Further comments:
There is room to support installations with root and boot on logical volumes
and the disk made into a physical volume for LVM2. This works perfectly with
lilo as the boot loader. I'm sure that grub could be patched to work with it
too. In the mean time we could just enable the user to use drives for
physical volumes when there are no partitions on them and the volume groups
tool should support this regardless. Also if a user has placed the /boot
files onto a logical volume, instead of informing that this isn't supported
we could instead inform that this is only supported with lilo as the boot
loader and then install lilo automatically instead of grub. These small
changes would have enabled me to complete my install as I wanted to in the

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: