[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#253724: marked as done (daily-20040515: some suggestions and typos)

Your message dated Wed, 08 Sep 2010 03:58:39 +0000
with message-id <E1OtBnz-000649-Li@ravel.debian.org>
and subject line Closing old installation report #253724
has caused the Debian Bug report #253724,
regarding daily-20040515: some suggestions and typos
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

253724: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=253724
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: normal


Debian-installer-version: 20040515 daily build for i386
uname -a: Linux nb-Spencer 2.4.26-1-386 #2 Sat May 1 16:31:24 EST 2004 i686 GNU/Linux
Date: 2004/05/17, ~1500h ADT.
Method: booted netinst CD (2.4 kernel)

Machine: P4 desktop, non-HT 2.8GHz Pentium 4 (Northwood), 512MB RAM.
nb-Spencer:~# fdisk -l /dev/hda
Disk /dev/hda: 40.0 GB, 40060403712 bytes
255 heads, 63 sectors/track, 4870 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1        2478    19904503+   7  HPFS/NTFS
/dev/hda2   *        2479        4808    18715725   83  Linux   <- root dev
/dev/hda3            4809        4870      498015    f  W95 Ext'd (LBA)
/dev/hda5            4809        4870      497983+  82  Linux swap
Output of lspci and lspci -n:  only ones of interest are:
0000:00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
0000:00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter

0000:00:04.0 Class 0200: 1039:0900 (rev 91)
0000:00:0d.0 Class 0200: 10ec:8139 (rev 10)
0000:01:00.0 Class 0300: 1039:6325

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]


 I conf'ed the network manually because udhcpc doesn't work at my site.  (the
far-superior dhclient in the test-candidate version works fine, so good job
getting that working.)  I was worried that wanting to use eth1 would be a
problem, but the menu to choose which nic worked great. :)

 GRUB installed fine, but it didn't have an entry for the winxp partition.
(which was re-sized and the disk repartitioned before I booted the
debian-installer).  I haven't re-tested with the test-candidate installer on
a machine that has a windoze partition, so I don't know if this is still a
problem.  I had to manually add the winxp partition to my GRUB menu.lst.
GRUB's config file has some typos: "default optons", and "specifiv".

 I also have some comments on base-config and the various packages' postinst
- The add user dialog had two versions of the same sentence: "Enter a full
name for the new user" displayed in the same dialog box.  I don't remember
if this is fixed in the test-candidate.

- /etc/hosts doesn't have entries for ip6-localhost, etc.  netbase's
postinst is supposed to add them.

- the installer never asked for a debconf question-ignore priority level.
I haven't made up my mind whether that's a bad thing or not.

-- X was set up for 800x600 and 640x480, even though the machine has a
1024x768 LCD screen (LG L1511S).  butt-ugly :(  I wish it used ddc-probed
monitor information, or at least read it with get-edid | parse-edid and put
that info into a dialog box.
-- I had to do a dpkg-reconfigure xserver-xfree86 to get a decent X setup.
It complained about  "cannot open /sys/bus/pci/devices", since I wasn't
running Linux 2.6, but it worked anyway.  It still didn't use probed values
for hsync and vsync, which is dumb on reconfig because all the binaries are
there for it to use to do any probing.  I don't remember everything I did,
but my notes indicate that after dpkg-reconfigure, the hsync/vrefresh values
were closer to the probed ones, and that the X server log file had a warning
line about "config file hsync range not within DDC".  I manually editted
XF86Config-4 after that.
-- The mouse setup (/dev/psaux and /dev/input/mice) will give a double-speed
mouse pointer if you run a 2.6 kernel with input support for ps/2 mice.
(The X server will get the mouse motion twice, once from each device file).
I don't know a way to write a config file that works well for 2.4 and 2.6 :(

 In short, the major hurdle for people who don't already know what they're
doing will be getting X running.  Modern hardware is so easily
autodetectable that it seems odd that the installer doesn't do as well with
X as with everything else.  (I guess Brandon's X stuff doesn't have anything
to do with debian-installer, but people setting up desktop machines do need
to configure X.  It looks like that's by far the hardest thing for a typical
desktop install, in terms of requiring detailed knowledge of how things are
supposed to work, and all your hardware specs.).

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.4.26-1-386
Locale: LANG=en_CA, LC_CTYPE=en_CA

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: