[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#250536: marked as done (Boot loader installation fails for both GRUB and LILO on hdb)

Your message dated Wed, 08 Sep 2010 03:58:38 +0000
with message-id <E1OtBny-00061a-FH@ravel.debian.org>
and subject line Closing old installation report #250536
has caused the Debian Bug report #250536,
regarding Boot loader installation fails for both GRUB and LILO on hdb
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

250536: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=250536
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: beta4 from debian web page
uname -a: didn't get that far
Date: 23 May 2004 13:00 - 18:00 MEST
Method: Booted CD-ROM using 100 MB image

Machine: Custom built but fairly standard
Processor: P III 1.2 GHz
Memory: 512 MB
Root Device: IDE, INTEL on-board
Root Size/partition table:
/dev/hda1  80 GB  --  Windows
/dev/hdb1 100 MB  --  /boot --  ext3
/dev/hdb2 512 MB  --  SWAP
/dev/hdb3  30 GB  --  /     --  XFS
/dev/hdb4  92 GB  --  /home --  XFS

Output of lspci: didn't get that far

Base System Installation Checklist:

Initial boot worked:    [0]
Configure network HW:   [0]
Config network:         [0] (see comment below)
Detect CD:              [0]
Load installer modules: [0]
Detect hard drives:     [0]
Partition hard drives:  [0]
Create file systems:    [0]
Mount partitions:       [0]
Install base system:    [0]
Install boot loader:    [E]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


This is my second try (first was with beta3 here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=240911 )

I still miss an ADSL option on network configuration (even if it would just skip the network configuration -- Having to put in bogus data that I know will later be replaced by my ADSL configuration is not "optimal")

I still have the same boot loader problems I had with beta3. I didn't try as extensively as last time (see above link for details) but the problem seems to be the same still:
- My setup contains a Windows partition on hda1, Debian is supposed to go on my new hdb hard drive using the XFS file system.
- I was unable to install a working GRUB or LILO on hdb or hdb1 (I want it there in order to dd the bootsector into a file and use that with the Windows bootloader -- this is the way I do it now with LILO and it works flawlessly)
- I tried all different combinations of GRUB and LILO with a /boot partition and without and with hdb1 and hdb as targets. I got some variants of L, GRUB, GRUB GRUB GRUB, GRUB GRUB GRUB GRUB ... (<- these are the error messages upon booting)
- Yes, I did the dd if=/dev/hdb1 of=bootsectorfile ... (using KNOPPIX) and copied the file over to the windows partition every time. The booting works on the Windows side because if I put my old hdb back in and remove the newly installed hdb and do this procedure my current system boots just fine.

- I inspected the generated lilo.conf in one of the tries WITH a /boot partition and noticed that it contains pointers to kernel and initrd.img in / (e.G. image=/vmlinuz). Now there are links to the correct files in the root filesystem but I wonder if lilo.conf shouldn't point directly to the files in /boot as the root filesystem is not yet accessible. I changed this manually in a chroot environment but that didn't do the trick either.
- If boot loader installation fails there is no way to boot the system. I would really appreciate a rescue image on the installer media. Then I could just try playing from within the running system to install a boot loader (as opposed to re-partitioning and re-installing just to try a new bootloader-approach)

Thanks for the hard work on the installer. Everything else works flawlessly and beautifully for me.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: