[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239826: marked as done ([i386] [beta3] [netinst] strangeness with partition resize, wrong fstab ordering, other minor issues)

Your message dated Wed, 08 Sep 2010 03:58:33 +0000
with message-id <E1OtBnt-0005qQ-KY@ravel.debian.org>
and subject line Closing old installation report #239826
has caused the Debian Bug report #239826,
regarding [i386] [beta3] [netinst] strangeness with partition resize, wrong fstab ordering, other minor issues
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

239826: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=239826
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: Debian-Installer beta 3
uname -a: Linux gingko 2.4.25-1-386 #1 Tue Feb 24 08:11:13 EST 2004 i686
Date: Tue Mar 23 14:04:26 EST 2004
Method: 100MB netinst + base cd iso

Machine: Dell Optiplex GX240
Processor: Intel(R) Pentium(R) 4 CPU 1.70GHz
Memory: 1 GB
Root Device: IDE - hda5
Root Size/partition table: (output of df and cat /proc/partitions below)

Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda5               459143     73044    361602  17% /
/dev/hda1                97826      9237     83370  10% /boot
/dev/hda2             35941928  20925444  13190700  62% /home
/dev/hda9             12365340   1321660  10415544  12% /usr
/dev/hda3             23963956  17089616   5657016  76% /usr/local
/dev/hda8               233335      4133    216754   2% /tmp
/dev/hda7              2403496    133072   2148332   6% /var
tmpfs                   452692         0    452692   0% /dev/shm

major minor  #blocks  name     rio rmerge rsect ruse wio wmerge wsect wuse running use aveq
   3     0   78177792 ide/host0/bus0/target0/lun0/disc 8471 38220 177502 36560 1873 3889 31656 31630 -2 667790 41671732
   3     1     104391 ide/host0/bus0/target0/lun0/part1 23 551 1148 660 8 1 18 70 0 570 730
   3     2   36515745 ide/host0/bus0/target0/lun0/part2 163 107 1794 2290 185 390 4592 1050 0 2450 3340
   3     3   24346507 ide/host0/bus0/target0/lun0/part3 22 56 258 180 17 7 168 110 0 290 290
   3     4          1 ide/host0/bus0/target0/lun0/part4 0 0 0 0 0 0 0 0 0 0 0
   3     5     489951 ide/host0/bus0/target0/lun0/part5 5190 26576 63532 11050 515 1749 4634 11780 0 11100 22830
   3     6    1461883 ide/host0/bus0/target0/lun0/part6 1 0 8 20 0 0 0 0 0 20 20
   3     7    2441848 ide/host0/bus0/target0/lun0/part7 181 128 2106 1830 789 1250 16328 12700 0 3360 14530
   3     8     248976 ide/host0/bus0/target0/lun0/part8 29 34 126 130 64 85 300 3830 0 900 3960
   3     9   12562798 ide/host0/bus0/target0/lun0/part9 2856 10750 108482 20320 295 407 5616 2090 0 17550 22410

Output of lspci: 

00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 12)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 12)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 12)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 12)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 12)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 12)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 12)
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro Ultra TF
02:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [E]
Mount partitions:       [E]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't
try it


great job!  

first i'll address the E's i listed above:

this system was previously running red hat 9, and once i finally pried
it away from the previous owner, i immediately popped in the sarge
installer.  i had two previously existing partitions that i wanted to
preserve during the install, /home and /usr/local, which are hda2 and
hda3 respectively.

so, i deleted all the other partitions, tried to resize hda3 a little
larger but changed my mind and hit cancel (in case it's significant),
created the new partitions, and chose "write changes to disk".

i was then prompted with the following error, twice:

	Not Yet Implemented!

	This ext2 filesystem has a rather strange layout.  Parted can't
	resize this (yet).

i was a little confused because i wasn't trying to resize any
partitions, perhaps my mucking with resizing options left some variable
set that should have been unset?  also, both hda2 and hda3 are ext3,
though i don't imagine that makes much of a difference.

anyway, it didn't prevent the rest of the installation from continuing,
and for the most part it went without a hitch.  however, upon rebooting, i
noticed that /usr/local wasn't mounted.  some testing revealed that
this was because /usr/local was listed before /usr in /etc/fstab, so
i'm guessing the call to mount failed because the mountpoint /usr/local
did not yet exist since /usr wasn't yet mounted.

it'd probably be a good idea for the script that generates fstab to do
some kind of sorting, placing the 1-level-deep mount points before the
2-level-deep mountpoints and so on -- or maybe patch mountall.sh/mount
to procede in that order.  i imagine this would also have been
a problem if i had set up a /var/log which was placed before /var etc.

the /usr/local thing was the only serious hitch that i encountered.  the
rest of this report is more general impressions / nitpicking:

- when selecting mountpoints, it'd be nice if previously selected
  mountpoints shouldn't show up in the list of optional mountpoints.
  that is, if i've already selected hda5 to be /usr, /usr shouldn't show
  up as an option when i'm editing hda6.

- it'd be nice if when you select "format this partition" that the
  filesystem type defaults to something reasonable, like ext3 (which i
  imagine would be the choice most of the time anyway)

- when specifying partition size, it'd be nice if default value was
  blanked out when the user typed in a size.  that is, if it says

  partition size: 17.4 GB
  and i type 200 MB, it'd be nice if it automatically blanked out the
  previously existing input.  i'm guessing that this probably isn't
  possible and is more a limitation of the menu system being used for
  the installer... feel free to ignore/scoff-at this one.

- an "experts only" option to use cfdisk/fdisk would be nice, though of
  course nothing would keep me from c-a-f2'ing to a shell and doing that
  myself (by the way, thanks much for arrows and tab completion in
  the installer shell!).  now that i think about it, if i did do the
  latter, would i have to get the installer to somehow refresh it's
  partition information?

- the partition symbols are a bit confusing, allbeit really cute.
  perhaps room could be made in the page for a key of some sort?  or
  perhaps a "help" option could be added to the bottom of the menu which
  would take the user to a page with a key and some other helpful

- a bootsplash would be nice for the default grub install.

- it'd be nice if you could remove pcmcia stuff on non-pcmcia systems
  like in the woody installer

- that's it!  i'll be getting some ultrasparc's in the coming weeks, and
  i'll give them a try -- though i notice there's only the 30MB iso for
  that.  any reason why?

anyway, once more, great job with the installer.  if i can provide any
more information or assistance, let me know.


Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: