[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239743: marked as done ([i386] [beta3] [netinst] broken partition table, download strangeness, nearly lost other contents of drive)



Your message dated Wed, 08 Sep 2010 03:58:33 +0000
with message-id <E1OtBnt-0005qB-HU@ravel.debian.org>
and subject line Closing old installation report #239743
has caused the Debian Bug report #239743,
regarding [i386] [beta3] [netinst] broken partition table, download strangeness, nearly lost other contents of drive
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
239743: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=239743
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Critical Bug

Debian-installer-version:
http://gluck.debian.org/cdimage/testing/sarge_d-i/i386/beta3/sarge-i386-netinst.iso

uname -a: 
Linux hpotter 2.4.25 #1 Thu Mar 18 21:45:23 PST 2004 i686 GNU/Linux

Date: March 22, 2004
Method: CD boot, attempt to DL packages off of http/ftp site

Machine: Home brew machine, MSI KT6 Delta LSR MB
Processor: AMD Barton 2500+ no OCing
Memory: 512 Mb

Root Device: WD 120 Mb HD (7200 rpm model)

Root Size/partition table: <Feel free to paste the full partition
      table, with notes on which partitions are mounted where.>

            see below

Output of lspci: (off of current, Sid, install)

daddy:~# lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host
Bridge (rev 80)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:07.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1
(rev 0a)
00:07.1 Input device controller: Creative Labs SB Live! MIDI/Game Port
(rev 0a)
00:0b.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T
(rev 01)
00:0f.0 RAID bus controller: VIA Technologies, Inc.: Unknown device
3149 (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. USB (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc.: Unknown device 3227
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235 AC97 Audio Controller (rev 60)
01:00.0 VGA compatible controller: nVidia Corporation: Unknown device
0342 (rev a1)


Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [E]
Mount partitions:       [E]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

I nearly lost all partitions on my HD after going through this.  I
seriously doubt I'm going to try this again until I have a whole disk
backup or another disk to use in its place.

The initial part of the installation seemed to go quite smoothly.  I
went into partitioning my hd as I wanted to create a new partition at
the end of the list to place the trial install on.  From cfdisk this is
my layout (before attempt, and now, after)

                                  cfdisk 2.12

                              Disk Drive: /dev/hda
                       Size: 120034123776 bytes, 120.0 GB
             Heads: 255   Sectors per Track: 63   Cylinders: 14593

    Name        Flags      Part Type  FS Type          [Label]
Size (MB)
 ------------------------------------------------------------------------------
    hda1        Boot        Primary   NTFS             []
15356.60 
    hda2                    Primary   W95 FAT32 (LBA)
6144.29
    hda3                    Primary   Linux swap
1027.23*
    hda5                    Logical   Linux ext2
1024.00*
    hda6                    Logical   Linux ext2
31.94*
    hda7                    Logical   Linux ext2
96.00*
    hda8                    Logical   Linux ext2
1023.94*
    hda9                    Logical   Linux ext2
2024.13*
    hda10                   Logical   Linux ext2
6144.13*
    hda11                   Logical   Linux ext2
4096.26*
    hda12                   Logical   Linux ext2
10240.48*
                            Logical   Free Space
72822.57*
    
The free space was to have a new partition placed on it.

I created that partition (hda13, 2.0 Gb), set it up to be formatted as
ext2, mounted as root, and used the regular swap (hda3).  The swap was
not identified as such in the listing so it was set up to be formatted
as well.

Movement from that point forward was apparently stymied by
slow/non-existent communication with mirrors. I don't know what the
problem was as the nic (a Broadcom based onboard chip) was detected
(from dmesg on tty2).  It consistently froze (nothing for minutes)
between 8 and 13% when getting packages.

In frustration, I rebooted (C-A-D).  I tried this a few times (2-3?)
with the same results on 2 different sittings during the evening. After
the second period, grub croaked with an error 17 (IIRC). 

I have a recovery partition on hda5, and my normal bootup on hda6
(/boot), hda7 ( / ), tmp, var, usr, and home on hda8-11. hda12 is a
backup partition.  hda1, hda2 is Wintendo XP.

Use of a grub floppy died, saying it couldn't read the partitions.  An
old Debian 2.2 CD was used to examine the partitions, wherein I
discovered that EVERY partition after the swap had been modified by
having a portion of it sliced off (amounting to 0.07 Mb in almost all
cases) and turned into free space between between each partition. I
couldn't tell at the time whether the slices had been taken off the
front or back of each. Each partition was flagged NC.

I took a chance and deleted the hda5 partition, then redefining it as
the total of it plus the free space slices about it. Rebooting suddenly
gave me a working grub menu (grub's base was on that partition).  The
regular installed base would not boot.  I could boot into the recovery
partition.

(Somewhere in this process I also deleted the new partition I had
created with the installer CD.  I honestly don't remember when but
believe it was from the Debian 2.2 CD, possibly at the same time I
modified the hda5 partition described above.)

>From hda5 I reasoned that the slices must have been taken off the front
of each partition.  This was tested by deleting the last partition
(hda12) and redefining it at the front of the free space area using the
size value I knew I had originally entered for it (10240 Mb). Writing
and rebooting gave me a readable hda12 with all the backup files.

Deleting the next partition in and redefining it to use all the
intervening free space gave a working /home partition. (You have no
idea how relieved I was about the above two, as they contained grades
and working documents for classes!)

Repeating this (and doing more than one partition at a time the last
run) gave recovered partitions for all but the original /boot (hda6).
This was expected since its slice disappeared into the original hda5
recovery when I redefined that partition.

The original /boot was fixed by (1) attempting to install my primary
partition's custom kernel on the recovery partition, which caused
depmod errors that I aborted out of, then copying the hda5 /boot
contents over to hda6.  This placed the kernel/map/config files onto
that partition. This was done in ignorance, BTW. I realized afterwards
that there are likely better ways to do it, but I'm no guru.  

That's all I can remmeber at the moment.  If anyone has questions,
please write.  

Kenward Vaughan
-- 
In a completely rational society, the best of us would aspire to be 
_teachers_ and the rest of us would have to settle for something less, 
because passing civilization along from one generation to the next 
ought to be the highest honor and the highest responsibility anyone 
could have.     - Lee Iacocca



--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
reasons:
- it was reported with a pre-lenny version of Debian
  Installer.
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful


The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.



--- End Message ---

Reply to: