[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239133: marked as done ([m68k] [20040320] [hd-media] various prolems)

Your message dated Wed, 08 Sep 2010 03:58:33 +0000
with message-id <E1OtBnt-0005pR-5R@ravel.debian.org>
and subject line Closing old installation report #239133
has caused the Debian Bug report #239133,
regarding [m68k] [20040320] [hd-media] various prolems
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

239133: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=239133
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


Debian-installer-version: <3/20/2004: http://people.debian.org/~smarenka/d-i/images-m68k/2004-03-20/mac/hd-media-vmlinuz-2.2.25-mac
& http://people.debian.org/~smarenka/d-i/images-m68k/2004-03-20/mac/hd-media-initrd.gz
uname -a: <Linux (none) 2.2.25-mac #1 Wed Mar 10 00:26:32 CET 2004 m68k unknown>
Date: <March 15, 2004 6:15 a.m. - 12:45 p.m.>
Method: Used hd-media kernel and copied the iso from 3/18/04 onto the macintosh hfs partition

What did you boot off?
I have 2 internal hard drives: sda, and sdb. I booted off sda and installed on sda. If network
Proxied? No.

Machine: <Macintosh Quadra 840AV>
Processor: Standard 68040 that came with the machine.
Memory: 64MB RAM
Root Device: < SCSI-Yes>
scsi : 1 host.
 Vendor: SEAGATE   Model: ST3600N           Rev: 9422
 Type:   Direct-Access                      ANSI SCSI revision: 01 CCS
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
 Vendor: SEAGATE   Model: SX19171W          Rev: 9D32
 Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
 Vendor: SONY      Model: CD-ROM CDU-8003A  Rev: 1.9a
Type: CD-ROM Detected scsi CD-ROM sr1 at scsi0, channel 0, id 4, lun 0

Root Size/partition table:

Disk /dev/sda
       #  type name          length   base    ( size )  system
/dev/sda1  map	Part Map	63   @	1	(31.5k)	Partition map
/dev/sda2  Drvr Driver_Parti	32   @ 64	(16.0k)	Driver
/dev/sda3  HFS	hktester    557160   @ 96	(272.1M) HFS
/dev/sda4 unix A/UX Root	251.3M
/dev/sda5 unix Swap	    128M
/dev/sda6 unix USR file system 914M
/dev/sda7 unix USR file system  475M

Block size=512, Number of Blocks=1025920

 Disk /dev/sdb
       #  type name           length   base     ( size )  system
/dev/sdb1   map Apple              63 @ 1        ( 31.5k)  Partition map
/dev/sdb2  Dr43 Macintosh          54 @ 64       ( 27.0k)  Driver 4.3
/dev/sdb3  Dr43 Macintosh          74 @ 118      ( 37.0k)  Driver 4.3
/dev/sdb4  ???? Patch Partit      512 @ 192      (256.0k)  Unknown
/dev/sdb5   HFS untitled      1228838 @ 704      (600.0M)  HFS
/dev/sdb6  unix root           716800 @ 1229542  (350.0M)  Linux native
/dev/sdb7  unix swap           262144 @ 1946342  (128.0M)  Linux swap
/dev/sdb8  unix /usr          6553600 @ 2208486  (  3.1G)  Linux native
/dev/sdb9  unix /home         9021026 @ 8762086  (  4.3G)  Linux native

Block size=512, Number of Blocks=17783111

Output of lspci:   bash: lspci: command not found

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [E] (had two scsi cds. Only a device for scd0 created, not for /dev/scd1
Load installer modules: [O]
Detect hard drives:     [E] Does show 2nd hard drives eventually, but not until after partitioning first with mac-fdisk
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E] libgcrypt7 failed to lood off of dibase-m68k.iso 3-1804 This effectively halted the install process using this iso image which was on the hfs partition. Image mounted successfully as a loop device. I checked the /debian/pool/main/libg/libgcrypt directory: it shows 1 file libgcrypt1_1.1.12-4_m68k.deb
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


<Description of the install, in prose, and any thoughts, comments
     and ideas you had during the initial install.>

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.
When asked which drive I wanted to partition, only received the option to partition to sda. sdb did not show up. So I was directed to mac-fdisk for /dev/sda. Which I had previously partitioned. So I entered <q> for quit. I was then directed to set up drive sda. Sdb did not show up on the list of choices again. So I entered drive a. Now sdb shows up on the table with sda. I select the partitions and hit enter on the partition I want to enter. This seems to work ok. This install was done with the new macintosh kernel and also tried with the regular nativehd-vmlinuz kernel. I believe Christian Steigies had installed the ext3 patch with this 2.2.25 kernel. I still was only offered the option of formatting the paritition as a ext2 partition. I guess I could have done this manually with the mkfs.ext3 command on another terminal. But the installer did not offer me that option. This is just a suggestion. [!!]Configure and mount partitions
When prompted with the list of partitions on the drives to setup to be formatted, I feel like I'm looking at a spreadsheet with no titles above the data types. If I didn't have a feel for what was going on, I certainly would have been confused. In fact, I was kind of skeptical about trying it for fear I might erase some partition. I notice that after entering a partition to be formatted and choosing a partition, then the name of the type of partition I chose shows up. I suggest 2 things: (1) names for the categories of data, and (2) a little more information  on the Configure and mount partitions screen.  The new installer is a big improvement over woody, but I feel it could be improved. Here's an example of what I would like to see:

Select a partition	Partition	size	type	mount point
			/dev/sda	n/a	n/a
			/dev/sda1	251 Mib	ext2	

The text says "This information shown is, in order: device name, size, file system, mount point."
This is helpful, but also somewhat confusing because the mount point does not show up until afterwards. I understood what was going on afterwards. But with a little more information, the installer would feel less intimidated. Here's some suggested text to insert:

Use your arrow keys to select a partition that you would like to format, hit the <enter> key to choose which type of filesystem you would like to use on this partition and the mount point. When you are finished configuring a partition, you will automatically return to this screen. When you are finished configuring your paritions, enter <Finish> to continue the installation process. Only the partitions that you configure for use will be used and formatted for your linux system. All other partitions will not be touched.

This information should educate the installer and help him to feel more comfortable with the configuration and mounting of his partitions.

This installer probably would have worked with the iso image, but for perhaps a badly named filename libgcrypt7, I'm guessing that it should have been libgcrypt1 ?

Also, I tried this install on a Quadra 605 with 36MB memory and received a message saying that I had very little memory. I should configure as soon as possible a swap partition to deal with the situation. Maybe at this point the debian installer should steal some of knoppix procedure when it discovers a "low" memory situation.
Prompt the user: "Would you like to set up a swap paritition now for use now?" And guide the user in setting up a swap partition for use during the install.



--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: