[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#278753: marked as done (Debian installation-reports Deskpro4000)

Your message dated Wed, 08 Sep 2010 03:57:45 +0000
with message-id <E1OtBn7-0004Dt-5N@ravel.debian.org>
and subject line Closing old installation report #278753
has caused the Debian Bug report #278753,
regarding Debian installation-reports Deskpro4000
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

278753: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278753
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: pre-rc2 i386 netinst CD image 2004-09-30 
              downloaded 2004-10-5 from http://cdimage.debian.org/

uname -a: [when booted from CD]
         Linux (none) 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i586
Date: 2004-10-24 (and other dates throughout the month)
Method: boot from CD
Machine: Compaq Deskpro 4000
Processor: Pentium 200MMX
Memory: 186 MB 
Root Device: IDE/ ATA -- Seagate ST32140A
Root Size/partition table: 
       Tried different partition arrangements, 
       including about 125 Mb for swap and 1.9 GB root.
       The first partition (21 Mb fat16, part#3) is the
       COMPAQ diagnostic partition so its BIOS won't
       complain about the drive. Root on anywhere from
       900 MB to 1.9 GB partitions.

Output of lspci and lspci -n: [when booted from knoppix CD]

[This includes the SCSI card I use for a scanner but does not include
the Ultra ATA card I originally was trying to use. I tried removing it
but the install just fails differently.]

> 0000:00:09.0 SCSI storage controller: Adaptec AHA-7850 (rev 01)
> 0000:00:0a.0 VGA compatible controller: Cirrus Logic GD 5446
> 0000:00:0b.0 Network controller: Compaq Computer Corporation
> Integrated NetFlex-3/P (rev 10)
> 0000:00:0f.0 ISA bridge: Compaq Computer Corporation Triflex PCI to
> ISA Bridge (rev 0a)
> 0000:00:0f.1 IDE interface: Compaq Computer Corporation Triflex Dual
> EIDE Controller (rev 0a)

> 0000:00:09.0 0100: 9004:5078 (rev 01)
> 0000:00:0a.0 0300: 1013:00b8
> 0000:00:0b.0 0280: 0e11:ae35 (rev 10)
> 0000:00:0f.0 0601: 0e11:a0f3 (rev 0a)
> 0000:00:0f.1 0101: 0e11:ae33 (rev 0a)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [E]


Installer and partitioner look good!

I have tried several times to install on this machine, and after
numerous failures went back to the Woody CDs to be sure, and Woody
installed fine.

With all the cards in the machine (including an Adaptec SCSI card I use
for a scanner and a SiL0680 card I installed for an Ultra ATA high
capacity drive) the kernel-image package installation fails. If I pull
out the Sil0680 card OR if I choose "expert" installation and turn off
most hardware detection, the installer fails before it gets to
kernel-image -- it complains that several (about 10) packages had
installation errors.

On the one time I got kernel-image to complete, (using "expert" install
AND turning off most hardware detection), the installed image was not

After lots of trial and error, I discovered that when I load a kernel
that DOES see the card, it wants to make the SiL card first, so I have
to change the root= kernel parameter from /dev/hda1 to /dev/hde1. That's
confusing (as if grub's device naming vs the /dev device naming wasn't
already confusing enough) but I can deal with it.

Starting with the successful Woody install, I tried installing other
kernel packages. HOWEVER when I install the 2.4.27 or 2.4.26 or 2.4.25
kernels, either 386 or 586tsc (pentium classic), everything starts
loading but then comes to a halt. On 2.4.27 it stops with a kernel
panic. On 2.4.26 it stops with the lines saying kjournald has started
and the EXT3-fs partitions have mounted, and just sits there. 2.4.25
says INIT: Id "1" respawning too fast (repeated with "2", "3", "4" etc.

DUH! With some more judicious Googling I realize I need to modify my
fstab file to point to the old drive in the new place. Makes sense,
doesn't it? So that means I can't switch back to the old working kernel
without switching fstab back. What a hassle. 

Maybe this explains why I had trouble installing Debian 3.0rc2 on this
machine... if the drive order changes depending on which driver gets
loaded first the installer gets as confused as I did. 

In fact, now I have a couple of strategies -- (1) install once without
the ATA card, then install the card and rescue-boot the PC from a CD and
edit the grub and fstab entries to accommodate it... yuk. Here's another
idea -- (2) give up on booting linux from the old drive -- just boot
from the big one. (There are a couple of reasons I don't want to do
this, but I may resort to it.) No, the COMPAQ BIOS won't let me boot
from the big drive (at least not without a lot of effort.

drat-- now I see that the fstab file and some other files are trashed,
probably because I let the PC sit there and try to boot with bad grub

Now I'm letting the Debian 3.0rc2 installer try again and yes... it
seems to confirm my theory about why it failed before.

OK so now I removed the SiL card and started Debian installer again. On
this slow machine I'll know in about 25 minutes (as opposed to about six
minutes on a 500 Mhz machine). !!!! yuk it failed again. 

SO the theory about the SiL card doesn't hold, BUT it's always possible
the Adaptec card confuses it too.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: