[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#278496: marked as done (Comments on RAID in partman)

Your message dated Wed, 08 Sep 2010 03:57:45 +0000
with message-id <E1OtBn7-0004Dj-32@ravel.debian.org>
and subject line Closing old installation report #278496
has caused the Debian Bug report #278496,
regarding Comments on RAID in partman
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

278496: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278496
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: Daily Build from 2004 Oct 21
uname -a: Has been updated to 2.4.27-1-686-smp (was possibly
Date: 2004 Oct 21 through 23
Method: Net-Install using sarge-i386-netinstall.iso

Machine: VA Linux 2230
Processor: Dual PIII 800mhz
Memory: 2 GB 
Root Device: SCSI disks in RAID array, more on this below...
Root Size/partition table: 

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          30      240943+  83  Linux
/dev/sda2              31        4466    35632170   fd  Linux raid
/dev/sdb1               1          30      240943+  82  Linux swap
/dev/sdb2              31        4466    35632170   fd  Linux raid
/dev/sdc1               1          30      240943+  82  Linux swap
/dev/sdc2              31        4466    35632170   fd  Linux raid

These are configured as a RAID5 array, in the following layout.

Filesystem            Size  Used Avail Use% Mounted on
/dev/md0               67G   24G   40G  38% /
tmpfs                 885M     0  885M   0% /dev/shm
/dev/sda1             221M   15M  194M   8% /boot

The /boot partition on /dev/sda1 is the important part.
(Yes, I know the allocation is sub-par.)

Output of lspci and lspci -n:

conflict:/home/gray# lspci
0000:00:00.0 Host bridge: Intel Corp. 440GX - 82443GX Host bridge
0000:00:01.0 PCI bridge: Intel Corp. 440GX - 82443GX AGP bridge
0000:00:0c.0 SCSI storage controller: Adaptec AIC-7896U2/7897U2
0000:00:0c.1 SCSI storage controller: Adaptec AIC-7896U2/7897U2
0000:00:0e.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro
100] (rev 08)
0000:00:12.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:12.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:12.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev
0000:00:12.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:14.0 VGA compatible controller: Cirrus Logic GD 5480 (rev 23)
0000:01:0f.0 PCI bridge: Digital Equipment Corporation DECchip 21150
(rev 06)

conflict:/home/gray# lspci -n
0000:00:00.0 0600: 8086:71a0
0000:00:01.0 0604: 8086:71a1
0000:00:0c.0 0100: 9005:005f
0000:00:0c.1 0100: 9005:005f
0000:00:0e.0 0200: 8086:1229 (rev 08)
0000:00:12.0 0601: 8086:7110 (rev 02)
0000:00:12.1 0101: 8086:7111 (rev 01)
0000:00:12.2 0c03: 8086:7112 (rev 01)
0000:00:12.3 0680: 8086:7113 (rev 02)
0000:00:14.0 0300: 1013:00bc (rev 23)
0000:01:0f.0 0604: 1011:0023 (rev 06)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Overall the installtion of the box using the daily build was not a
problem. I used the daily build to try out the RAID support recently
added to partman. Everything worked absolutely great after I figured
out one small catch with /boot partition. It appears that when using
software RAID it is necessary to have the /boot part on at least one
partition outside of the array so that grub or lilo can be installed.
Without knowing this I went through a number of trial and error
configurations until I had the array set up correctly. Initially I
mistakenly tried to make the RAID array bootable using the interface.
This failed on all partition attempts. It occurred to me that a boot
block on the RAID didn't make sense, so it may be wise to remove the
ability to flag the /dev/md devices as bootable. As a result the /boot
partition was necessary. I would recommend adding a dialog that the
/boot partition is necessary for root raid installations. This will 
help other new users of the RAID installation tools to avoid these 

Matthew P. McGuire <gray AT shadowglade.net> 1024D/E21C0E88
CB82 7859 26B2 95E3 1328  5198 D57A D072 E21C 0E88
          When choice matters, choose Debian.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: