[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#275216: marked as done ([i36][pre-rc2][netinst] I2O Intel RAID controller not supported)

Your message dated Wed, 08 Sep 2010 03:57:42 +0000
with message-id <E1OtBn4-000489-8P@ravel.debian.org>
and subject line Closing old installation report #275216
has caused the Debian Bug report #275216,
regarding [i36][pre-rc2][netinst] I2O Intel RAID controller not supported
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

275216: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=275216
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: downloaded sarge-i386-netinst.iso pre-rc2 from
http://cdimage.debian.org on 20041004.
uname -a: Linux godzilla 2.6.8-1-686 #1 SMP Tue Oct 5 18:01:38 CST 2004
i686 GNU/Linux
Date: Oct 5 10:00:00 CST 2004
Method: Installed using a custom built cdimage since the installer
    dindn't have the drivers for my RAID controller. Completed the
    install from the network.
Machine: Intel pentiumIII Xeon with an Intel I2O RAID controller.
Processor: Intel pentiumIII Xeon 1GHz x 2
Memory: 1GB
Root Device: SCSI discs on raid1 on an Intel I2O RAID controller. Root
    device is /dev/i2o/hda1.
Root Size/partition table:
godzilla:~# fdisk -l 

Disk /dev/i2o/hda: 18.2 GB, 18299748352 bytes
255 heads, 63 sectors/track, 2224 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/i2o/hda1		1          33      265041   83  Linux
/dev/i2o/hda2	       34         155      979965   82  Linux swap
/dev/i2o/hda3         156        2224    16619242+   5  Extended
/dev/i2o/hda5         156         204      393561   83  Linux
/dev/i2o/hda6         205         690     3903763+  83  Linux
/dev/i2o/hda7         691        1298     4883728+  83  Linux
/dev/i2o/hda8        1299        2224     7438063+  83  Linux

Output of lspci and lspci -n:
godzilla:~# lspci
0000:00:00.0 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
0000:00:00.1 Host bridge: ServerWorks CNB20LE Host Bridge (rev 06)
0000:00:02.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC
215IIC [Mach64 GT IIC] (rev 7a)
0000:00:03.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro
100] (rev 08)
0000:00:06.0 PCI bridge: Intel Corp.: Unknown device 9620 (rev 02)
0000:00:06.1 I2O: Intel Corp. Integrated RAID (rev 02)
0000:00:0f.0 ISA bridge: ServerWorks OSB4 South Bridge (rev 50)
0000:00:0f.1 IDE interface: ServerWorks OSB4 IDE Controller

godzilla:~# lspci -n
0000:00:00.0 0600: 1166:0009 (rev 06)
0000:00:00.1 0600: 1166:0009 (rev 06)
0000:00:02.0 0300: 1002:4756 (rev 7a)
0000:00:03.0 0200: 8086:1229 (rev 08)
0000:00:06.0 0604: 8086:9620 (rev 02)
0000:00:06.1 0e00: 8086:9621 (rev 02)
0000:00:0f.0 0601: 1166:0200 (rev 50)
0000:00:0f.1 0101: 1166:0211

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [O]

. The debian-installer cdimage I downloaded didn't have the modules for
I2O hardware, so I had to built a custom boot disc using
linux-kernel-di-i386-2.6-0.66 and debian-installer-20040801 to add the
I2O modules to a mini.iso cdimage.
. debian-installer didn't load the modules for the RAID controller, so I
had to manually load them:
    modprobe i2o_block
    modprobe i2o_config
    modprobe i2o_proc
Once the modules where loaded the installer recognized the discs and
offered me the option to partition them. Devices /dev/i2o/hda/disc,
/dev/i2o/hda/part1, /dev/i2o/hda/part2... got created automatically.
. when installing the base system kernel-image-2.6.8-1-686 installation
failed with the message:
    Setting up kernel-image-2.6.8-1-686 (2.6.8-3) ...
    /usr/sbin/mkinitrd: /dev/i2o/hda/part1: Unknown root device
                        Please refer to the manual page.
    Failed to create initrd image.
and base system installation failed. I fixed this by making my own
kernel-image-2.6.8-1-686_2.6.8-3 that didn't use an initrd and
installing it before debian-installer got to installing the kernel.
. when I tried to install the grub boot loader it failed since it did
not recognise /dev/i2o/hda/disc as a BIOS boot drive. Then I tried to
install the LILO boot loader but that step just returned without doing
. after installing grub manually I booted and completed the debian
installation. But when I rebooted to test everything I couldn't boot
since the device names where changed from /dev/i2o/hda/part1 to

Alberto Brealey Guzmán

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: