[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#271423: marked as done (Floppy driver not loaded during install process on OldWorld PowerPC Macs)

Your message dated Wed, 08 Sep 2010 03:57:38 +0000
with message-id <E1OtBn0-00040R-SD@ravel.debian.org>
and subject line Closing old installation report #271423
has caused the Debian Bug report #271423,
regarding Floppy driver not loaded during install process on OldWorld PowerPC Macs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

271423: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=271423
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

powerpc BootX 20040911 businesscard OldWorld PowerMac

see note 6


Debian-installer-version: <Fill in date and from where you got the image>

	Index of /pub/cdimage-testing/daily/powerpc/current
	 Name                           Last modified       Size  Description
	 Parent Directory               12-Sep-2004 00:13      -
	 MD5SUMS                        12-Sep-2004 00:13     1k
>>>	 sarge-powerpc-businesscard.iso 12-Sep-2004 00:07   140M
	 sarge-powerpc-netinst.iso      12-Sep-2004 00:13   297M
	Apache/1.3.31 Server at cdimage.debian.org Port 80

uname -a: <The result of running uname -a on a shell prompt>

Linux debian 2.6.8-powerpc #1 Fri Aug 27 18:02:26 CEST 2004 ppc GNU/Linux

Date: <Date and time of the install>

	3:00 AM US East Coast time Sept 12, 2004

Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?

	MacOS BootX using the "2.6" kernel and initrd.gz
	from the install/powerpc folder on the indicated
	businesscard CD image with an assist from the
	uchicago "testing" mirror

Machine: <Description of machine (eg, IBM Thinkpad R32)>

	PowerMac G3/300 MHz


	processor   : 0
	cpu         : 740/750
	temperature         : 36-41 C (uncalibrated)
	clock               : 300MHz
	revision    : 2.2 (pvr 0008 0202)
	bogomips    : 601.29
	machine             : Power Macintosh
	motherboard : AAPL,Gossamer MacRISC
	detected as : 48 (PowerMac G3 (Gossamer))
	pmac flags  : 00000000
	L2 cache    : 1024K unified pipelined-syncro-burst
	memory              : 384MB
	pmac-generation     : OldWorld


	384 MB

Root Device: <IDE?  SCSI?  Name of device?>

	root is on /dev/hdg10.  Swap is on /dev/hdg8. macOS is on /dev/hdg6

# type name length base ( size ) system /dev/hdg1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map /dev/hdg2 Apple_Driver43 Macintosh 54 @ 64 ( 27.0k) Driver 4.3 /dev/hdg3 Apple_Driver43 Macintosh 74 @ 118 ( 37.0k) Driver 4.3 /dev/hdg4 Apple_Driver_IOKit Macintosh 512 @ 192 (256.0k) Unknown /dev/hdg5 Apple_Patches Patch Partition 512 @ 704 (256.0k) Unknown /dev/hdg6 Apple_HFS untitled 2097152 @ 1216 ( 1.0G) HFS /dev/hdg7 Apple_UNIX_SVR2 root 19531251 @ 2098368 ( 9.3G) Linux native /dev/hdg8 Apple_UNIX_SVR2 swap 1953126 @ 21629619 (953.7M) Linux swap /dev/hdg9 Apple_UNIX_SVR2 root 19531251 @ 23582745 ( 9.3G) Linux native /dev/hdg10 Apple_UNIX_SVR2 Root-10 5859376 @ 43113996 ( 2.8G) Linux native /dev/hdg11 Apple_Free Extra 52734377 @ 48973372 ( 25.1G) Free space /dev/hdg12 Apple_Free Extra 113607707 @ 206565349 ( 54.2G) Free space /dev/hdg13 Apple_UNIX_SVR2 SuZq 104857600 @ 101707749 ( 50.0G) Linux native
	Block size=512, Number of Blocks=320173056
	DeviceType=0x0, DeviceId=0x0
	1: @ 64 for 23, type=0x1
	2: @ 118 for 36, type=0xffff

Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
Output of lspci and lspci -n:

	0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10) 0000:00:0e.0 SCSI storage controller: Artop Electronic Corp ATP865 (rev 06) 0000:00:0f.0 PCI bridge: Hint Corp HB6 Universal PCI-PCI bridge (non-transparent mode) (rev 13)
	0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)
	0000:01:08.0 USB Controller: NEC Corporation USB (rev 41)
	0000:01:08.1 USB Controller: NEC Corporation USB (rev 41)
	0000:01:08.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
0000:01:0b.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)
	0000:00:00.0 0600: 1057:0002 (rev 40)
	0000:00:0d.0 0200: 1186:1300 (rev 10)
	0000:00:0e.0 0100: 1191:0009 (rev 06)
	0000:00:0f.0 0604: 3388:0021 (rev 13)
	0000:00:10.0 ff00: 106b:0010 (rev 01)
	0000:00:12.0 0300: 1002:4754 (rev 9a)
	0000:01:08.0 0c03: 1033:0035 (rev 41)
	0000:01:08.1 0c03: 1033:0035 (rev 41)
	0000:01:08.2 0c03: 1033:00e0 (rev 02)
	0000:01:0b.0 0c00: 104c:8020

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [o]
Configure network HW:   [?]
Config network:         [?]
Detect CD:              [o]
Load installer modules: [o]
Detect hard drives:     [o]
Partition hard drives:  [o]
Create file systems:    [?]
Mount partitions:       [o]
Install base system:    [o]
Install boot loader:    [ ]
Reboot:                 [?]


<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

Note 1:

	This machine has a SCSI Zip drive is on the apple
	"mesh" scsi controller.  Before the "discover disks"
	phase, I had to go to the F2 console and manually
	"modprobe mesh" to get it to recognize the Zip disk.
	 Because the mesh driver module was loaded behind
	d-i's back (so to speak), d-i didn't know about it,
	and as a result, "mesh" wasn't carried forward to
	/etc/modules after the reboot. (see note 3)

	Many (most?) oldworld PowerMac's have the "mesh"
	scsi controller as their *only* (and in any case
	*primary*) mass-storage interface.  Failure to load
	the mesh driver module will make it impossible for
	inexperienced users to install Debian on their
	machines.  It seems to me that the mesh driver
	should be loaded by default on *all* oldworld
	PowerMac machines.

	The problem is made more complicated because the
	"mesh" chip is on the motherboard, and so doesn't
	show up in the output of "lspci".  This only
	strengthens the argument for loading the mesh driver
	by default.

Note 2:

	"Select Keyboard" defaults to "European", even though
	I answered all the location (US) and language
	(English) questions up to then so as to indicate
	that "American English" was the appropriate default.
	I manually chose the "American English" keyboard
	I don't know if it's related, but after the reboot,
	perl and man (among others) complained about the the
	locale being not supported or installed.  The
	/etc/environment file contained:
	I would have thought that "en_US" should have come
	first in "LANGUAGE" and (maybe) replaced "en" as the
	correct value for "LANG".

Note 3:

	This machine has two ethernet interfaces.  One is directly
	on the motherboard and uses the "bmac" driver.  It supports
	10-Base-T only.  The other is on a PCI card from D-link and
	uses the "8139too" driver.  It supports 100-Base-T.  I
	want to use the faster (D-link) card, and ignore the slower
	(bmac) card.  Every time d-i did a hardware detect phase
	(both "discover network hardware" and "discover disk
	hardware"), it offered to load the "bmac" driver for me.
	Each time it offered, I specifically declined (un-checked
	the "bmac" button on the options list).  I also chose the
	"D-link" card as my "primary" network interface when it
	Nevertheless, after the reboot, in the /etc/modules
	file, there it was -- big as life, first thing in
	the file -- "bmac".  Consequently, the "bmac" driver
	module was loaded before the "8139too" module, and
	the bmac interface was accorded status as "eth0".
	DHCP failed as a result. Interestingly, there was no
	mention of "8139too" in the /etc/modules file at
	all.  I assume it was loaded by some other mechanism
	than the /etc/modules file.
	When I edited /etc/modules so that the first three lines
	it was able to do DHCP and it was able to see my SCSI Zip
	drive (see note 1).

Note 4:

	When it asked which kernel to install, near the end
	of the first part of the installation process, the
	default was the 2.6.7 kernel, even though 2.6.8 was
	available and listed among the options. I manually
	chose kernel-image-2.6.8-powerpc.

Note 5:

	After the reboot, I told it to install the "print server"
	task.  Possibly as a consequence of the locale anomaly
	mentioned in note 2, the setup for that task gave me the
	default option of "a4" paper.  I manually chose "letter", as
	befits my location in the US.

Note 6:

	Every time it tried to discover hardware (both "network" and
	"disks") it offered me a chance to load the "floppy (Linux
	Floppy)" driver.  Each time I told it to go ahead (left the
	relevant button checked).  Each time, according to the logs,
	it failed to load that driver.
	During the first phase of the installation, I
	attempted to mount a floppy disk, remembering my
	troubles with previous tests to save log files to a
	floppy.  It failed.  With a mac formatted (HFS)
	floppy in the drive:
		# mkdir /mnt
		# mount -t hfs /dev/floppy/0 /mnt
		mount: Mounting /dev/floppy/0 on /mnt failed: No such device
	interestingly, after the reboot the floppy drive was
	recognized.  But there was no "/media/floppy" directory.
	Isn't this the usual mount point for floppy disks?
	Is it relevant that the OldWorld PowerMacs used a "swim"
	floppy controller, which requires a different software
	driver from the floppy controllers usually used in PCs?

Note 7:

	While the partitioner was "checking" my swap
	partition (why does it do that?  It takes a long
	time.  What is actually being accomplished?) I
	switched to the F2 console and looked at
	"/proc/swaps".  It appears that the partitioner is
	checking an *active* swap partition!  This is not a
	problem for large memory machines, but it may be a
	serious problem on a small memory machine.

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: