[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#270773: marked as done (Difficult Install PowerPC)

Your message dated Wed, 08 Sep 2010 03:57:38 +0000
with message-id <E1OtBn0-0003yR-00@ravel.debian.org>
and subject line Closing old installation report #270773
has caused the Debian Bug report #270773,
regarding Difficult Install PowerPC
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

270773: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=270773
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: rc1
uname -a: 2.4.25
Date: 9/8/04
Method: root.img floppy image, then netinst

Machine: Apple Macintosh G3
Processor: 266 Mhz PowerPC G3
Memory: 384
Root Device: IDE /dev/hda6
Root Size/partition table: 
/dev/hda6 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hda10 on /home type ext3 (rw)
/dev/hda9 on /tmp type ext3 (rw)
/dev/hda7 on /usr type ext3 (rw)
/dev/hda8 on /var type ext3 (rw)

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0d.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)
0000:00:0e.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
0000:00:0e.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
0000:00:0e.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
0000:00:0f.0 Ethernet controller: 3Com Corporation 3c590 10BaseT [Vortex]
0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 5c)

lspci -n
0000:00:00.0 0600: 1057:0002 (rev 40)
0000:00:0d.0 0300: 121a:0005 (rev 01)
0000:00:0e.0 0c03: 1106:3038 (rev 50)
0000:00:0e.1 0c03: 1106:3038 (rev 50)
0000:00:0e.2 0c03: 1106:3104 (rev 51)
0000:00:0f.0 0200: 10b7:5900
0000:00:10.0 ff00: 106b:0010 (rev 01)
0000:00:12.0 0300: 1002:4750 (rev 5c)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [ ]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


What a major pain! This was sooo much easier to when it was woody. To start with, I'll have to submit some info on installing w/ BootX 
for the other hapless souls out there who try to install on a beige G3...

I had to play around with getting started, as the docs don't yet reflect the changes wrought. So...the 2.6.7 kernel doesn't work with my
G3/266, as I've got a voodoo3 card, and I get no video. I mentioned in another email that I'll set up a serial console to figure out 
what's up with that, but I won't be able to fix it. I've not had any success with 2.6.x kernels and voodoo3. I just get a blank screen. 
So, I used a 2.4.25 kernel with ext3 compiled in. 

Using BootX, I booted with root.img as my start image off the hard drive as the ramdisk. No matter how many different ways I tried, 
the initrd.gz ramdisk never worked for my install. I would get a kernel panic about ... something. I saw a similar message to mine in an 
archive after googling for it, but it didn't mean anything. What filesystem does initrd.gz use, anyway? What must be compiled into the
kernel for this to work?

The thing about the root.img is that the assumption is that you'll continue to use floppies. Since I faked out the system by using BootX
to load the ramdisk image into memory, I figured I could switch over to getting the other things I need from a CD that I'd burned. But 
that didn't work, since apparently "once a floppy install, always a floppy install." Fortunately, I didn't need any other drivers from 
any other floppy. Also, I found that /target doesn't seem to hold on to settings like mounting /dev/cdrom onto /floppy...once you exit 
the console to go back to the installer, it's gone. 

I didn't like the way that skipping the "install additional drivers from floppy" kept giving me the red screen that gave dire warnings
of a failed step. Woody did that better, too, with a list of items, and that one just staying at the top. Once I've skipped a step, I 
don't need to be reminded over and over that I've skipped it. I did eventually get to the next step and completed the install, but ...

As far as getting the install: in two or three of the apt lists, England, aka UK, aka United Kingdom, aka Great Britain, aka Britain...
is listed all over the place in its various forms. It should be consistent throughout with the same name. And why not be able to add a
second/third apt source? 

And what's up with having to have your root partition be ext2 in order to install quik? It doesn't seem that debian wants to play nice 
with the other OS I have running on my computer (Mac OS), either. I put ext3 on all my partitions (the default)...there should be some
explanation of why you chose ext3 as the default, and how to change it to something else. The partitioning program seemed a bit slow
in doing its thing. The partition program also didn't allow a surface check of the disk, which I needed...I've been having problems with 
my disk, so on an install this would have been a good thing. I didn't want to go back to woody for just this one thing. I think I was
just having problems with xfs filesystem though, as I haven't had any with ext3. 

Last thing is that I tried to install the Desktop system from Tasksel, and none of the desktop stuff installed because one package, 
kdegraphics, didn't install. That's just stupid. The whole thing shouldn't fail because one package is missing. 


--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: