[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#270599: marked as done (Floppy install on Oldworld PowerMac)

Your message dated Wed, 08 Sep 2010 03:57:37 +0000
with message-id <E1OtBmz-0003y7-Qy@ravel.debian.org>
and subject line Closing old installation report #270599
has caused the Debian Bug report #270599,
regarding Floppy install on Oldworld PowerMac
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

270599: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=270599
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
        powerpc boot-floppy 20040906 OldWorld PowerMac


Debian-installer-version: <Fill in date and from where you got the

I got the floppy disk images from:

     Index of /~luther/d-i/images/daily/powerpc/floppy-2.4
     Name                    Last modified       Size  Description

     Parent Directory        26-Aug-2004 21:35      -
     asian-root.img          06-Sep-2004 22:38   1.2M
     boot.img                06-Sep-2004 22:38   1.4M
     cd-drivers.img          06-Sep-2004 22:39   1.4M
     net-drivers.img         06-Sep-2004 22:39   1.4M
     ofonlyboot.img          06-Sep-2004 22:39   1.4M
     root-2.img              06-Sep-2004 22:41   1.4M
     root.img                06-Sep-2004 22:42   1.3M
    Apache/1.3.26 Server at people.debian.org Port 80

uname -a: <The result of running uname -a on a shell prompt>

    Linux debian 2.6.7-powerpc #1 Thu Aug 5 23:48:59 CEST 2004 ppc

Date: <Date and time of the install>

    4 AM (UTC) 2004-09-07

    How did you install?

	boot/root/driver floppies with an assist from the uchicago mirror

    What did you boot off?

        boot floppy

    If network install, from where?




Machine: <Description of machine (eg, IBM Thinkpad R32)>

    PowerMac G3/300 MHz


    processor	: 0
    cpu		: 740/750
    temperature 	: 36-41 C (uncalibrated)
    clock		: 300MHz
    revision	: 2.2 (pvr 0008 0202)
    bogomips	: 601.29
    machine		: Power Macintosh
    motherboard	: AAPL,Gossamer MacRISC
    detected as	: 48 (PowerMac G3 (Gossamer))
    pmac flags	: 00000000
    L2 cache	: 1024K unified pipelined-syncro-burst
    memory		: 384MB
    pmac-generation	: OldWorld


    384 MB

Root Device: <IDE?  SCSI?  Name of device?>

    Didn't get that far

Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

Output of lspci and lspci -n:

    0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
    0000:00:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet
(rev 10)
    0000:00:0e.0 SCSI storage controller: Artop Electronic Corp ATP865
(rev 06)
    0000:00:0f.0 PCI bridge: Hint Corp HB6 Universal PCI-PCI bridge
(non-transparent mode) (rev 13)
    0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
    0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage
I/II 215GT [Mach64 GT] (rev 9a)
    0000:01:08.0 USB Controller: NEC Corporation USB (rev 41)
    0000:01:08.1 USB Controller: NEC Corporation USB (rev 41)
    0000:01:08.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
    0000:01:0b.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26
IEEE-1394 Controller (Link)

    0000:00:00.0 0600: 1057:0002 (rev 40)
    0000:00:0d.0 0200: 1186:1300 (rev 10)
    0000:00:0e.0 0100: 1191:0009 (rev 06)
    0000:00:0f.0 0604: 3388:0021 (rev 13)
    0000:00:10.0 ff00: 106b:0010 (rev 01)
    0000:00:12.0 0300: 1002:4754 (rev 9a)
    0000:01:08.0 0c03: 1033:0035 (rev 41)
    0000:01:08.1 0c03: 1033:0035 (rev 41)
    0000:01:08.2 0c03: 1033:00e0 (rev 02)
    0000:01:0b.0 0c00: 104c:8020

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [?] Note 1 
Configure network HW:   [o]
Config network:         [o]
Detect CD:              [ ]
Load installer modules: [o]
Detect hard drives:     [e] Note 2
Partition hard drives:  [?]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

Note 1:

The "ofonlyboot" floppy booted and gave me the "tuxmac" icon in the
middle of the screen.  After the floppy noises stopped, the screen
inverted colors, but did not switch to text mode.  The ofonly boot
floppy ejected.  Normally, at this point it's calling for the root
floppy, so I gave it the root floppy and hit <return>.  As expected,
it read the root floppy, but the text screen never appeared -- just
the inverted color tuxmac.  So it was impossible to proceed further
with the "ofonlyboot" experiment.

Then I tried the "boot" floppy.  It gave me the tuxmac and made
reading noises.  After a while it ejected the boot floppy and switched
to a text mode screen at (I think) 640x480 resolution.  This is good
enough for installing -- but not satisfactory for long term usage.

It called for the root floppy, so I fed it that, which it read
happily.  After reading the root floppy and asking me some questions
about languages and locations, it asked if I wanted to read a driver
floppy.  I said yes and fed it the "root-2" floppy.

My choice of "root-2" at this point was based on a hunch.  There was
no indication of which driver floppy it was expecting (Indeed, it was
not clear at all that "root-2" was a "driver" floppy.  My hunch was
that it would be needed immediately and that the easiest way to add
files to the ram-disk root was to emulate a driver floppy.)  It would
be better to out-and-out say "root-2" if that's what is wanted.

It then tried to detect my network interface and failed, so it asked
for the network drivers floppy, which I gave it.  This time it
succeeded in finding my network interface and configured it via DHCP
(I would have preferred the option to do this manually, but there is no
way to specify "DEBCONF_PRIORITY=medium" in booting an oldworld pmac
machine from floppy.)  It asked for a mirror, and I specified the
uchicago one since it seems to be fastest and most reliable from my
little corner of the Internet.

Note 2:

Things proceeded more or less as expected until it came time to
partition the disk.  The partitioner could not find any disks to
partition!  Switching to the F2 console and poking about, it became
clear that this was *not* just a problem with the partitioner -- the
only ide device present, as far as the kernel was concerned, was the
CD-ROM drive.  My IDE disk was nowhere to be found!  There was no
"/dev/discs" directory, and there was just the CD-ROM drive in the
/proc/ide directory.  Very strange!

Final note:

Throughout this process, except for once when it asked for the "root"
floppy, it never ejected the previous floppy.  On a Mac, this means I
have to manually eject the floppy with a bent paperclip.  Mac floppy
drives do not have an "eject" button the way PC floppy drives do.
This is annoying to experienced folks, and will be confusing to
inexperienced users.

Question in parting:

It never asked for the CD-drivers floppy.  Should it have?

Install logs and other status info is available in
Once you have filled out this report, mail it to submit@bugs.debian.org.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: