[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#270417: marked as done (Re: Package: base-config (Installation does not work with boot loader NOT in MBR))

Your message dated Wed, 08 Sep 2010 03:57:37 +0000
with message-id <E1OtBmz-0003xn-MR@ravel.debian.org>
and subject line Closing old installation report #270417
has caused the Debian Bug report #270417,
regarding Re: Package: base-config  (Installation does not work with boot loader NOT in MBR)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

270417: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=270417
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: base-config

i have a big problem installing Debian Sarge (offical snapshot vom
on a PC with an
external Boot-Manager (Bootstar) and some different Windows-Versions on
I want to install the Linux on Partition 10 (Partition 11 is Swap) on
There was a Mandrake-Distribution installed on the Partition before and
there was no problem
to boot it with the Bootstar-Bootmanager.
First i have installed Sarge on the Partition and i have choosen to
Grub and when it asks to install it
on the MBR i have choosen "No".
But Grub was installed on the MBR and has overwritten the Bootstar.
The Linux did boot with no problem but i could not boot any other
After i had reconstructed the Bootstar i installed Sarge again and tried
to take Lilo to install on /dev/hda1.
The Menu "crashes" with stripes on the screen.
Bootstar was not overwritten, but Linux boots with the graphical Lilo of
Mandrake and brakes on starting Cron!
I tried a 3rd Insallation with Lilo and it ends with overwriting the
I have edited the lilo.conf to start lilo from /dev/hda1 and repairs the
But it does not work. I can boot Windows but the "Mandrake-Lilo" starts
So the bug is that the Install-Routine can't install the boot-loader on
It only works with installing in the MBR.
Another problem is that i can't but from CD or Diskette.
When i enter boot: "linux root=/dev/hda1" it crashes with
VFS: Mounted root (ext2 filesystem)   -> I have installed ext3 ! (Is the
choice of ext 2 better ?)
Mounted devfs on /dev
VFS: Cannot open root device "hda1" or unknown-block(0,0)
Please append a correct "root=" boot option
-> Bootstar is mapping the Partition tables
All Partitions before 10 seems to be not partitionized. Partition 10
be the first partition.
Kernel panic VFS: Unable to mount root fs on unknown-block(0,0)
So what can i do ?
How can i install Lilo or Grub on /dev/hda1 ?
The other problem is that i can't boot Linux with CD or Diskette to edit
Thank you for response.
Best regards

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: