[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#267515: marked as done (Installer RC1 [fails on older ISA SCSI boards])

Your message dated Wed, 08 Sep 2010 03:57:35 +0000
with message-id <E1OtBmx-0003tW-Ml@ravel.debian.org>
and subject line Closing old installation report #267515
has caused the Debian Bug report #267515,
regarding Installer RC1 [fails on older ISA SCSI boards]
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

267515: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=267515
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version:  RC1
uname -a:   N/A
Date:  8/22/2004  2140 EDT
Method: How did you install?  Tried both CD and network.
	What did you boot off?  Floppy
	If network install, from where?  ftp://debian.uchicago.edu  Proxied?  No.
	Connected through masquerading hardware firewall box.

Machine:  Compaq Deskpro
Processor:  Pentium 1  133 MHz
Memory:     32 MB
Root Device: SCSI?  Yes.  Name of device?  /dev/sda3
Root Size/partition table:
/dev/sda1 	50 MB	/boot
/dev/sda2	268 MB	swap
/dev/sda3	1.8 GB	/
/dev/sdb1	839 MB	/var
/dev/sdb2	1.3 GB	/home

Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 430HX - 82439HX TXC [Triton II] (rev 01)
0000:00:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21041 [Tulip Pass 3] (rev 11)
0000:00:07.0 ISA bridge: Intel Corp. 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II]
0000:00:0f.0 VGA compatible controller: Cirrus Logic GD 5436 [Alpine]

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [E]
Load installer modules: [O/E]
Detect hard drives:     [E]
Partition hard drives:  [ ]
Create file systems:    [E]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


  The basic problem that showed up here is that D-I doesn't know what to do
with a device that can't be auto-detected.  A lot of contemporary installers
are like that.  If the device isn't automatically detected, the installer
doesn't automatically load its driver module.
  Unfortunately, it doesn't ask the user whether any modules need to be
loaded manually.  Older installers did this, when ISA devices that couldn't
be auto-detected were common.  For example, Red Hat 4.0 had dialogues asking
whether there were any SCSI devices, and if so, what kind of board, I/O
address, and interrupt line.  The need for this has not gone away, and it
will never go away.
  To put this in perspective, the machine has a non-bootable SCSI CD-ROM and
two SCSI hard disks, all connected to an AHA-1542 ISA non-PNP SCSI host
adapter.  There is also an IDE disk, but that is not the install target. 
The target drives presently run Sarge, installed by first installing
Libranet 2.7 on the IDE drive, then cross-installing Woody from the network
to the SCSI drives and upgrading to Sarge.  So the hardware all works, and
has been for years.  LN 2.7 or RH 6.2 boots from floppy and installs from

1.  Booted OK from the RC1 floppy set.  First tried the CD drivers floppy. 
Failed to detect CD; no activity lights on SCSI bus.  lsmod didn't show the
aha1542 driver.  Checked /lib/modules/2.4.26-1-386/kernel/drivers/scsi. 
aha1542.o was not present.  No Adaptec driver modules were present.
This is fatal to any attempt to install from a SCSI CD drive.
Went back to "Load drivers from a floppy".  Read in the drivers from the
network driver floppy.  Still no Adaptec drivers.

2.  Continued on to attempt a network install.
The command line to start the installation had been
	expert netcfg/disable_dhcp=true
but the option had no effect.  The installer still asked if DCHP should be
tried.  I said no.
It started up a dialog to configure a static IP address.  It didn't ask
which of the 3 Ethernet interfaces on the machine should be used.  I had to
move cables around until I found which one it had made eth0.  Otherwise,
configuration was successful.  Apparently, it auto-detected the Tulip PCI
board, but didn't detect either of the two NE-2000 clone ISA PNP boards, and
didn't ask whether there were any other network interface boards.

3.  During "Loading components of the Debian Installer" it hung at 46%,
"Retrieving md-modules".  Killing the wget process and re-trying got it
going again.  It hung at random places just about every time on previous d-i

4.  The partitioner started up.  It displayed only the partitions on the IDE
disk.  No activity lights flashed on the SCSI bus.  lsmod showed some
scsi-related modules loaded, but not aha1542.  This time it was present in
the /lib tree.  Commanded
	modprobe aha1542
The partitioner still displayed only the IDE partitions.
Went back to "Detect hardware".  No SCSI activity.
Tried partitioner.  No disk partitions at all were displayed.
Tried fdisk.  It couldn't detect any disks at all.


5.  Re-ran it, without using the CD drivers floppy this time.
The "Loading components" download hung at a different spot, otherwise same.
Executed the modprobe command before starting the partitioner for the first
The partitioner listed all three drives.  fdisk didn't detect any.

/dev/sda1 	50 MB	/boot
/dev/sda2	268 MB	swap
/dev/sda3	1.8 GB	/
/dev/sdb1	839 MB	/var
/dev/sdb2	1.3 GB	/home

Tried to select /dev/sdb so a filesystem could be created in it for a new
installation.  System hung with a blue screen on console #1..  Last message
on console #3 was
	insmod isofs
	No matching physical volumes found
	No volume groups found
	Reading all physical volumes.  This may take a while...
Last message on console #4 was
	Aug 22  22:49:25 main-menu[376]: DEBUG: virtual package harddrive-detection

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: