[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#266970: marked as done (installreport of august17 netinst snapshot)

Your message dated Wed, 08 Sep 2010 03:57:35 +0000
with message-id <E1OtBmx-0003sb-9q@ravel.debian.org>
and subject line Closing old installation report #266970
has caused the Debian Bug report #266970,
regarding installreport of august17 netinst snapshot
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

266970: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=266970
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

uname -a: Linux Si 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i586 GNU/Linux
Date: started wget at: Wed Aug 18 02:15:04 CEST 2004
      burned cd at   : 03:15:02
      started install shortly after that.
Method: experimental install image, burned to a cdrom (see above),
        retrieved rest of packages off net, from german primary mirror 
(ftp.debian.de ?)
Machine: i386 pc
Processor: pentium1 mmx 200MHz
Memory: 196MB
Root Device: /dev/hda , 80 GB maxtor harddisk
Root Size/partition table:
	 hda1		 Primary	 Linux ext2	 [/boot]	   98.71
	 hda2	 Boot	 Primary	 Linux ext3	 [woody2]	 3997.49
	 hda3		 Primary	 Linux swap			   98.71
	 hda5		 Logical	 Linux ext2	 [Potato5]	 3997.49
	 hda6		 Logical	 Linux ext2	 [/home]	 3997.49
	 hda7		 Logical	 Linux ext2	 [/my]		 3997.49
	 hda8		 Logical	 Linux ext2	 [Woody8]	 3997.49
	 hda9		 Logical	 Linux ext3	 [Woody9kde]	 3997.49
	 hda10		 Logical	 Linux ext2	 [Woody10]	 3997.49
	 hda11		 Logical	 Linux ext2	 [Sarge11]	 3997.49
	 hda12		 Logical	 Linux swap			 3997.49
	 hda13		 Logical	 Linux ext2	 [Reunie]	 3997.49
	 hda14		 Logical	 Linux ext2	 [Sound]	 3997.49
	 hda15		 Logical	 Linux ext3	 [Redhat15]	 3997.49
	 hda16		 Logical	 Linux ext2			 3997.49
	 hda17		 Logical	 Linux ext2			 3997.49
	 hda18		 Logical	 Linux ext3			 3997.49
	 hda19		 Logical	 Linux ext2			 3997.49
	 hda20		 Logical	 Linux ext3			 3997.49
	 hda21		 Logical	 Linux ext2			 3997.49
			 Logical	 Free Space			 9804.54

Output of lspci:
	0000:00:00.0 Host bridge: Intel Corp. 430TX - 82439TX MTXC (rev 01)
	0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
	0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
	0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
	0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
	0000:00:08.0 VGA compatible controller: ATI Technologies Inc 3D Rage II+ 
	  [Mach64 GTB] (rev 9a)
	0000:00:0d.0 Ethernet controller: Linksys NC100 Network Everywhere Fast 
	  10/100 (rev 11)
	0000:00:0e.0 Ethernet controller: Realtek Semiconductor Co., Ltd. 
	  8139C+ (rev 10)
	0000:00:0f.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 

Base System Installation Checklist:

Initial boot worked:    [ok ]
Configure network HW:   [ok ]
Config network:         [errors ]
Detect CD:              [ok ]
Load installer modules: [worked ]
Detect hard drives:     [ok ]
Partition hard drives:  [worked ]
Create file systems:    [ok ]
Mount partitions:       [error ]
Install base system:    [ok ]
Install boot loader:    [error? ]
Reboot:                 [ok ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it



burned cd, and mounted it, and read README.txt, which is a bit strange,
  seems to be written for an entirely different CD,
  it even says to bear in mind that this is an unofficial CD,
  while it really is an official snapshot.


at bootsplash, i type 'expert26', because i want to use lilo

messages flash by,
  among last of these i see 'FATAL: module hid not found'
  fortunately install continues.

I am presented with menus,
  but without explanation of which keys to use to traverse them.

Kernel modules are loaded,
  and i am notified 'unable to load some modules',
  notably all modules i need for network cards are apparently unloadable
  this is a bit disquieting, but install proceeds.

at 'load installer components', 'continue' is not default

network devices are detected correctly,
  and now drivers for them can be loaded !?!

at 'detect network hardware' i am told about modules that are not yet 
  notably ide-scsi, ide-mode, ide-probe-mod, ide-detect, ide-floppy,
  but afaik these are not needed for network hardware, ide-scsi is for cdrom.
  also, term 'unable to' is a bit alarming to me.

skipping 'configure the network', as instructed
  (i am not told that installer only installs minimal bootable system
   and network isnt needed for that; but expert should know that;
   and it probably wouldnt have hurt if i had configured it.)

same questions about pcmcia asked again.

same 'unable to load some modules' message is shown again,
  only now in a box titled 'detect hardware'.

choosing manual partitioning,
  because i have a large harddisk, and many partitions,
  and i experienced sudden disappearance of partitions in woody once,
  when i had manually added addidtional device nodes for very many partitions;
  so i take opportunity to let installer create partitions for me.

creating new partitions /dev/hda15,16,17,18,19,20,21 each 4 GB,
  most of them ext2, 18 and 20 ext 3, not mounting them.

installer recomputes partition table after every partition added,
  takes 35 seconds each time (on my 200 MHz machine).

use /dev/hda11 as ext2 and mount root on it
use /dev/hda6  as ext2 and mount /home on it
use /dev/hda1  as ext2 and mount /boot on it
cant mount /dev/hda7 on /my because i cant edit mountpoints,
  and because /my is not a standard directory
use existing swap partition /dev/hda3 as swap

it would be nicer if partition table showed labels,
  as i use these to tell me what i use each partition for

there is no option 'errors=ro', so i used defaults for root partition

'configure software raid' &co do not mention that
  i dont need to run through them,
  but ok, it is expert partitioning.

lots of warnings for unassigned mountpoints

'"the" ext2 filesystem passed a basic test' is popped up 3 times in a row,
  perhaps mention which filesystem that was ?
  i am happy to find that program is not in a loop...

attempt to mount swap failed
  (that swap partition was always used without problems
  when running woody (which has its root on hda10)).
  at time of failure report, progress bar had already reached 100%
i go back to partitioner, tell it to use hda12 as swap too (4GB).
this still fails,
  failure to swapon hda3 seems to prevent hda12 from being tried,
  so i go back to partitioner and set hda3 to be unused,
  now it works.

i missed mention of availability of other VTs,
  and also this installer doesnt have helpfull screens there that woody had.

hda21 does disappear after reboot, as noted furtheron,
  though it is only nonexistent devicenode, and not partitiontable getting 


this seems to hang, but continues after a couple of minutes
  (i see on VT4 that kernels are discovered)
'install lilo' offers me bootblock on MBR or on /dev/hda1
  while hda1 is for mounting /boot, and root is on hda11,
  so i choose advanced.
default target for lilo is /dev/ide/hosts/bus0/target0/lun0/disc
  but that is my ide-scsi cdrw,
  and installing a bootblock on it might be a problem,
  so i change it to /dev/hda11
this gets me an
  "ERROR: /dev/hda11 does not represent a partition or harddisk device"
  so i let it put bootblock in MBR.

when it is time to reboot, cdrom is auto-ejected; this is good !
  (i remember re-entering installer a couple of times 
    when i installed potato)

kernel detects NICs correctly, and loads correct drivers for them,
  but i cant connect to mirrors,
so i escape to another VT and do ifconfig,
  which shows me that i have no configured interfaces,
  not even lo !
so after some false tries (because what used to be eth0 is now eth1)
  if do 'ifconfig eth1 mtu 1496' and 'dhclient eth1'
  and then i still have no lo, but ftp works.

i select 'manual package selection', expecting to find dselect,
  but get aptitude ;
i need to press random keys to find aptitude help
aptitude starts with a blank screen
  (i hadnt selected 'desktop' then, because i was going to do it manually)
aptitude's display of dependency info is a pleasant feature!
i can only select from a very limited subset of packages.
i unselect gnome and kde; while i do use k apps,
  in woody i found kdm to be too hard to get rid of,
  i prefer using olvwm as windowmanager,
  and dont want to download whole gnome or kde over my 30 kB/s link.

downloading 111 MB takes an hour or so.

'fontconfig' (never heard of that) wants to know whether to
  also make available bitmapped fonts for "applications that use fontconfig"
  how should i know answer to that ?
  still i select non-default 'yes'; i can always delete it later.
likewise, i never heard of 'freetype autohinter',
  and if even fontconfig doesnt know whether this makes fonts look
  uglier or more beautifull, why bother me ?

x now offers me option of allowing all console users to log in to x ;
  hooray ! (i hope), as i this was often troublesome to me.
i am told about xserver's nice value,
  and that it should be 0 for new O(1) scheduler in 2.6 kernel,
  and i did select 2.6 kernel, so why ask me ?
'autodetect videocard' defaults to 'no',
  but as i am optimistic i select 'yes',
  driver 'ati' seems ok.
xserver::pci asks a question that is only for powerpc's and indy's,
  and i am on i386 , so why ask me ? (architecture should be easy to detect)
i select autodetection of mouse,
  'please select entry that best describes your mouse'
  only thing i recognize in these names is 'ps2', but they all have that,
  so i go with default.
i make educated guesses about hsync and vsync,
  data on what i could use in woody are on hda10,
  and i dont want to interfere with setting up base system now,
  so i dont mount anything;
  also, my mach64 was previously no quite correctly detected,
    in that i couldnt set higher dotclock than 175M,
    while card's identifying strings say it can do 200,
    perhaps that is fixed now;
  also, i need to set exact video timings, as my monitor detects
    current video modes, and uses stored settings for each one,
    and i have tweaked these (back when XF86Config4 didnt exist yet);
  also, videomodes are not limited by my monitor,
    but by visual flicker, dotclock, and 2MB of onboard RAM.

"ttf-bitstream-vera\n Fontconfig error. cannot load default config file"


mkdir /mnt/part21
mount -t ext2 /dev/hda21 /mnt/part21
-> "mount: special device /dev/hda21 does not exist"
ls /dev | grep hda
-> only first 20 partitions and raw device

-> fails, but has nice, informative graphical messagewindow
   it says that i dont have a windowmanager (as i expected)
   and that i dont have a terminal-emulator either
mouse works ok, i can click messagewindow's 'ok' button
screen needs some tweaking ofcourse,
  but generally x seems to work smoothly out of the box :-)
back at console, xauth complains
  'bad display name "Si:0" in "remove" command'.

so grab olvwm from net...
ifconfig shows still eth1 up and no lo
running dselect...
  selecting olvwm, xterm, xemacs
downloading 102 packages, 83 MB (40MB for xemacs), in nearly an hour,
startx works, i can run bash in a terminal window,
  but still have no xemacs; it seems to be unavailable !?!
install elvis, purge lpr,nfs,ispell,mutt,wamerican,iamerican,ibritish
  (why install spelling corrector by default ?
   i am wiseguy myself, i dont need machine for that !)

perhaps 'run sshd' better default to 'no' for innocent users ?

elvis works easy enough (i use it now), but i cant delete newlines.

Si:/# kbdrate -r 30
Typematic Rate set to 30.0 cps (delay = 250 ms)
Si:/# hdparm -d 1 /dev/hda
bash: hdparm: command not found
  (not installed yet) why is this not standard ?

Si:/# setcolor fg light red , bg white
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_CTYPE = "en_US.UTF-8",
        LANG = (unset)
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

These perl warnings are repeated many times,
  for every package being configured, for example;
  i'lld like to get rid of them !
  but i dont know how to set a locale :-(
  (ok i can find out if needs be, but i think it is a bug.)
I did not see any configuration menus or questions about locale,
  neither during install nor during base-config.


now to biggest part of work :
  configuring exim4 (hope that didnt change too much),
  configuring x
  configuring lilo, so it'll recognize my other debian partitions
  setting up usernames and numbers
  running dselect and looking through each and every package !
    (is there a way to feed it list of package that i in woody decided
     should/shouldnot be installed, and then copying their status,
     and grouping rest together as 'new' packages ? 
     unfortunately, i think it doesnt exist.)

so far installation took me ca 8 hours minus time to write this

now when i try to install (nonfree) calctool,
  i see its name being hyjacked by gcalctool,
  and tons of dependencys being pulled in, even scrollkeeper !
  and that to get an ugly grey simple calculator !
  instead of nice-coloured small calctool.

and no multitasking with dselect,
  cannot select next bunch to download while current download runs !
  (this probably also was like this, but i just got permanent internet
   connection working since last weekend.)

installing debsig-verify immediately changes behaviour of dselect,
  making it fail for all packages to be installed next.
as failure occurred after it was successfully installed,
  i first suspected debsigs (and then debsums, until it dawned on me)

installed a dozen editors, found emacs21(x11), using that now,
  now atleast i can delete newlines,
  so i can edit configuration files of exim (and find and read exim4 docs)
    so that i can actually mail this report.
  this emacs21 is not as good as xemacs, though,
    so i hope that be in testing soon.

used dired to find notes i made prior to installation, and pasted them above.
cut&pasted template from browser
filled in answers to questions

time is now Thu Aug 19 05:04:14 CEST 2004,
  getting some sleep and configure exim tomorrow.
Why doesnt exim4 suggests exim4-doc-html ?

Konqueror::Location::OpenLocation::'click browse button' crashes konqueror,
  it becomes completely unresponsive, and i need to use xkill.

need to create /etc/network/interfaces content ; it contained only a comment
  next time i reboot it should be allright.
did 'ifconfig lo up ; ifconfig lo'
  success, can now ping localhost

think i created good exim4.conf ,
  but now local testmail was refused because root is on list of never_users,
  is exim being run by root, or can root not use mail ?
setting up some usernames/numbers first...

i purged sqlrelay, but this did not remove user sqlrelay

kmail lowercases hostnames specified in it's settings popup,
  in woody this caused rewriting in exim to fail,
  i already have double rewriting rules in exim4.conf

installed fetchmail and fetchmailconf ;
  fetchmailconf fails with a socket error in line 2028 "name or service not 

reinstalled exim, is invoked as exim4 -bd -q30m by init,
  so not run by inetd.
could have made it reread it's configfile by sending it SIGHUP
kmail run as siward can not connect to localhost
kmail run as root (with default identity set to siward) just says 
  'failed to send some messages'  ie all messages.
can grab mail with fetchmail now. (had accidentally uninstalled at)
  but cant read them normally yet, as i had not yet set /etc/email-addresses
  only via /var/spool/
messages received with fetchmail are not delivered,
  because (says /var/spool/exim4/msglog) it is run as root,
  while commandline seen in top is clearly invoked by Debian-exim

fetchmail now tries to connect to my popservers without authenticating,
  this is always refused,
  upon which fetchmail repolls immediately with user/pass
  it didnt do this in woody, and i dont like it.

i can send mail with kmail if i set smtp.wanadoo.nl in it's settings,
  (ie if i dont use exim)
but i cant retrieve mail from pop.wanadoo.nl due to authorization failure,
  despite me providing same password to kmail's popup as
  one that is in .fetchmailrc that works
  (perhaps it lowercases that too?)

changed /etc/aliases ,
   replacing every instance of root by siward, except root:siward
   (siward is in group mail)

user Debian-exim is not in group mail, added it to that group.

well, i'll try to send install-report now
no need to cc me on replys, i wont be able to receive your mails
(but i'll use webinterface to read installer list)

one  nuisance i encountered also was dselect's 
  'do you want to erase any downloaded debs'
  defaulting to yes,
  while being slow and unresponsive
     and newlines accumulate  in keyboardbuffer
'yes' can not be corrected, undoing 'no' would be easy.

Well, i hope this helps any,
  installer worked well overall, just a few bugs,
  debian installation did not work so well,
  a system without mail means continuous rebooting.
  but now i have some nice new packages to use,

  thanks for your good work.


--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: