[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#266547: marked as done (d-i netinstall on oldworld powerpc using daily iso 20040816)

Your message dated Wed, 08 Sep 2010 03:57:35 +0000
with message-id <E1OtBmx-0003sN-64@ravel.debian.org>
and subject line Closing old installation report #266547
has caused the Debian Bug report #266547,
regarding d-i netinstall on oldworld powerpc using daily iso 20040816
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

266547: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=266547
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


Debian-installer-version: CVS Netinstall ISO 20040816
uname -a: Linux niobe 2.6.7-powerpc #1 Thu Aug 5 23:48:59 CEST 2004 ppc GNU/Linux
Date: 17.08.2004
Method: How did you install?  
        * Netinstall with ISO holding base-debs

        What did you boot off?  
 * tried CD-Rom, didn't work, tried yaboot, didn't work. Contacted
debian-powerpc@l.d.o and was enlightened that i have an "oldworld Mac".
Got BootX from the Net (was not included on CD) and bootet the powerpc
vmlinux with initrd (2.6.7 kernel). Worked ok.

        If network install, from where?  Proxied?
 * I was intending to leech the rest off the net, yet everything d-i
needed was on the CD already. Thus i didn't need the Inet connection.

Machine: Apple PowerPC 233MHz (oldworld, no idea what exact model)
processor       : 0
cpu             : 740/750
temperature     : 23-25 C (uncalibrated)
clock           : 233MHz
revision        : 2.1 (pvr 0008 0201)
bogomips        : 465.92
machine         : Power Macintosh
motherboard     : AAPL,Gossamer MacRISC
detected as     : 48 (PowerMac G3 (Gossamer))
pmac flags      : 00000000
L2 cache        : 512K unified pipelined-syncro-burst
memory          : 320MB
pmac-generation : OldWorld

Memory: 320MB
Root Device: /dev/hda8 (QUANTUM FIREBALL ST4300A, ATA DISK drive)
Root Size/partition table:  
# mac-fdisk -l
        #                    type name                length   base    ( size )  system
        /dev/hda1     Apple_partition_map Apple                   63 @ 1       ( 31.5k)  Partition map
        /dev/hda2        Apple_Driver_ATA Macintosh               54 @ 64      ( 27.0k)  Unknown
        /dev/hda3        Apple_Driver_ATA Macintosh               74 @ 118     ( 37.0k)  Unknown
        /dev/hda4      Apple_Driver_IOKit Macintosh              512 @ 192     (256.0k)  Unknown
        /dev/hda5           Apple_Patches Patch Partition        512 @ 704     (256.0k)  Unknown
        /dev/hda6               Apple_HFS Ohne Titel         2048000 @ 1216    (1000.0M)  HFS
        /dev/hda7         Apple_UNIX_SVR2 swap               1757813 @ 2049216 (858.3M)  Linux swap
        /dev/hda8         Apple_UNIX_SVR2 untitled           4611787 @ 3807029 (  2.2G)  Linux native

        Block size=512, Number of Blocks=8418816
        DeviceType=0x0, DeviceId=0x0
        1: @ 64 for 21, type=0x701
        2: @ 118 for 34, type=0xf8ff

/dev/hda8 is root, /dev/hda7 is swap, /dev/hda6 is the MacOS 9.1 partition (not currently mounted)
Output of lspci and lspci -n:
# lspci
0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)

# lspci -n
0000:00:00.0 0600: 1057:0002 (rev 40)
0000:00:10.0 ff00: 106b:0010 (rev 01)
0000:00:12.0 0300: 1002:4754 (rev 9a)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O] 
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]

After some hazle to find out this was an oldworld Mac, the boot went
pretty straight. Quik didn't want to install onto ext3 -> start over,
made a /boot in ext2 format. Quik wanted /boot and / on one partition 
-> start over, removed /boot, made / ext2. Quick from the d-i CD
couldn't install for some reason -> always getting red screen telling it
didn't work. No HFS partition mountable without specifying debconf-prio
to medium (which i didn't supply), thus no copying of vmlinux and initrd
from the installed Debian to HFS. Copied to the network and moved back
from MacOS. Could boot Debian with new kernel (after i had found out i
do need the initrd image too) and upgraded to SID. Now quik installed ok
onto /dev/hda8. Yet no effect while bootup, still facing MacOS without
any question if i'd prefer to have Debian. Before this successful
booting, i had tried to boot with the d-i CD vmlinux and no initrd to
root=/dev/hda8 => Kernel panic, no root found. Neither as /dev/hda8 nor
as /dev/ide/host0/bus0/target0/lun0/part8.

Concluding, i'd wish to see some small MacOS tool on the d-i CD that i 
could run and which would tell me "You have an oldworld Mac. Go and get
BootX NOW". That way i'd be easier to not loose like 3h to yaboot and  
OpenFirmware trying to make it work in vain. Apart from that, if BootX 
could be shipped on the d-i CD aswell, that might help doing just a    
quick test too I still wonder what's wrong with the quik setup. There's
no errors anymore, everything works ok and tells me that it's installed
now. Yet i don't get around the MacOS->BootX->Debian sequence.

(Install logs and other status info is available in /var/log/debian-installer/.)

Please let me know if you need anything else. 

Best regards,

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: