[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265192: marked as done (Installation Report: problems with fb, missing prompt, grub not installed)

Your message dated Wed, 08 Sep 2010 03:57:34 +0000
with message-id <E1OtBmw-0003qp-FR@ravel.debian.org>
and subject line Closing old installation report #265192
has caused the Debian Bug report #265192,
regarding Installation Report: problems with fb, missing prompt, grub not installed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

265192: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=265192
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/daily/i386/20040811/sarge-i386-netinst.iso
uname -a: Linux natty 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i686 unknown
Date: Thu Aug 12 00:07:18 2004
Method: Installed from cd image
Machine: Gateway 2000
Processor: Pentium II (Klamath) 300Mhz
Memory: 95M
Root Device: IDE, /dev/hda
Root Size/partition table:
Partition Table for /dev/discs/disc0/disc
               First       Last
 # Type       Sector      Sector   Offset    Length   Filesystem Type (ID) Flag
-- ------- ----------- ----------- ------ ----------- -------------------- ----
 1 Primary           0     3871664     63     3871665 OpenBSD (A6)         Boot
 2 Primary     3871665     8851814      0     4980150 GNU HURD or Sys (63) None
 3 Primary     8851815     9992429      0     1140615 Minix / old Lin (81) None

I was attempting to install to partition 2.
Output of lspci:
0000:00:00.0 0600: 8086:7180 (rev 03)
	Flags: bus master, medium devsel, latency 32
	Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [a0] AGP version 1.0

0000:00:01.0 0604: 8086:7181 (rev 03)
	Flags: bus master, 66MHz, medium devsel, latency 96
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	Memory behind bridge: f0000000-f7ffffff

0000:00:07.0 0601: 8086:7110 (rev 02)
	Flags: bus master, medium devsel, latency 0

0000:00:07.1 0101: 8086:7111 (rev 01) (prog-if 80 [Master])
	Flags: bus master, medium devsel, latency 64
	I/O ports at fc90 [size=16]

0000:00:07.2 0c03: 8086:7112 (rev 01)
	Flags: bus master, medium devsel, latency 64, IRQ 11
	I/O ports at fca0 [size=32]

0000:00:07.3 0680: 8086:7113 (rev 02)
	Flags: medium devsel, IRQ 9

0000:00:0d.0 0401: 1274:5000
	Subsystem: 4942:4c4c
	Flags: bus master, slow devsel, latency 96, IRQ 10
	I/O ports at fcc0 [size=64]

0000:00:0e.0 0200: 10b7:9050
	Flags: bus master, medium devsel, latency 64, IRQ 9
	I/O ports at fc40 [size=64]

0000:00:0f.0 0100: 9004:8178 (rev 01)
	Subsystem: 9004:7881
	Flags: bus master, medium devsel, latency 64, IRQ 5
	I/O ports at f800 [disabled] [size=256]
	Memory at fedff000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [dc] Power Management version 1

0000:01:00.0 0300: 110b:0004 (rev 41)
	Subsystem: 10b4:1f29
	Flags: bus master, 66MHz, fast devsel, latency 66, IRQ 9
	Memory at f0000000 (32-bit, non-prefetchable) [size=128M]
	Capabilities: [48] Power Management version 1
	Capabilities: [58] AGP version 1.0

Base System Installation Checklist:

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


There seemed to be two problems relating to video:

1. At the splash screen, the "Press F1 for help, or ENTER to boot:"
prompt is missing.  The rest of the splash screen looks fine.  If I
type something, I don't see the characters I typed on the screen.
Pressing F1 gives the help screen, which looks okay.  Now I can see
the characters I typed before next to the boot prompt.

2. I erase the characters I typed and press ENTER.  The kernel and
root image unpack okay and I see the beginning of normal kernel init
messages, or at least one or two screens of them,   until it reaches a
message saying, "Trying to create..."  I couldn't read fast enough to
see the rest before the screen went blank and my monitor started
hissing loudly.  

Both these problems (the missing prompt up front and the hissing
later) happen both with the default 2.4 kernel and the 2.6 kernel.  I
also tried with the rc1 netinst cd as well and got the same
behaviour above.

If I give the argument to disable the framebuffer, I can get through
to debian installer and begin installing.  It proceeds okay, but then
I get the following problems (continuing with the 11/08 cd install):

i) It fails to detect openbsd on the first partition of the disk.  I
mean, it allows me to keep the partition, but when it comes to
installing grub, it makes the statement: "It seems that this
installation of Debian is the only operating system on this computer."
But it does warn that it might not be correct about that and that I
won't be able to boot the other operating system unless I can
configure grub to do so, so this does not seem a very serious problem
to me, and I continue...

ii) I choose to install grub in the mbr.  The progress bar reaches 50% and then
I get an error dialog: 

[!!] Install the GRUB boot loader on a
    Unable to install GRUB in (hd0)
Executing 'grub-install (hd0)' failed.

This is a fatal error

   <Go Back>       <Continue>

I went back and copied as much as I thought would be useful to a
floppy.  If someone wants any of them I can provide the dmesg,
messages, syslog, or partman logs.

I thought it was interesting that the last message in messages is the

The file /boot/grub/stage1 not read correctly.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: