[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#593492: debian-installer: Unable to install debian using RAID5, dm-crypt, LVM

Package: debian-installer
Severity: normal

I am unable to install lenny (5.0.5), i386 using RAID5, dm-crypt and LVM.

I got
/dev/sda (2TB)
/dev/sdb (2TB)
/dev/sdc (2TB)

and want to install the system unsing RAID5.

I use:
/dev/sda1 (256MB)
/dev/sdb1 (256MB)
/dev/sdc1 (256MB)

/dev/sda2 (about 4TB)
/dev/sdb2 (about 4TB)
/dev/sdc2 (about 4TB)

Configure Sofware-RAID
	New RAID1
		/dev/sda1, /dev/sdb1, /dev/sdc1

	New RAID5
		/dev/sda2, /dev/sdb2, /dev/sdc2

RAID5 #1
	physical Volume for encryption
	Erase data: No

Configure encrypted device
	Enter password 2 times

Encrypted device (md1_crypt)
	physical Volume for LVM

Configure Logical Volume Manager
	Add volume-group
		Name: volgroup
		Use md1_crypt

	Create logical volume
		root, 20GB
		swap, 2GB
		home, (remain)

LV home

LV root

LV swap

RAID #0 (256 MB)

When I try to go on with the installation, I get the error
"The kernel was unable to re-read the partition table on /dev/md0 (Invalid argument).
This means Linux won't know anything about the modifications you made
until you reboot.  You should reboot your computer before doing
anything with /dev/md0."

The automatically provided system-information can be ignored.

-- System Information:
Debian Release: squeeze/sid
  APT prefers lucid-updates
  APT policy: (500, 'lucid-updates'), (500, 'lucid-security'), (500, 'lucid')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-24-generic (SMP w/8 CPU cores)
Locale: LANG=de_AT.utf8, LC_CTYPE=de_AT.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: