[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#592770: Daily build d-i + lenny + GRUB2: "Unable to install GRUB in /dev/sda"

Package: debian-installer
Version: 20100805-15:58
Severity: important

I am attempting to install lenny with GRUB2 using a daily build of d-i.
After being prompted whether or not to install to the MBR, I get a red-
screen error as follows:

    [!!] Configuring grub-pc

    Unable to install GRUB in /dev/sda
    Executing 'grub-install /dev/sda' failed.

    This is a fatal error.

Looking at the log on tty4, I see what appears to be the output of "grub-
install --help", and then

    error: Running 'grub-install --no-floppy --force "/dev/sda"' failed.

The only instance of "grub-install" that I can find is under /target,
and if I invoke that as shown in the log, I get

    Unrecognized option `--force'

If I drop the --force option, I get

    /target/usr/sbin/grub-install: .: line 121: can't open '/usr/lib/grub/update-grub_lib'

Reply to: