[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lilo removal in squeeze (or, "please test grub2")


After some discussion about lilo on #debian-devel in IRC, it has pretty
much been determined that kernel sizes have crossed the line past where
lilo can reliably determine the payload size.

This bug *can* be fixed, but not without a significant rewrite of the
way that lilo's stage2 loader code works.  Given that there is no active
upstream and that the Debian lilo package carries many patches for bug
fixes that are alleviated by standardizing on grub2, this seems like the
best option for Debian.

This means that users should *test grub2 extensively* before Squeeze is
released so that any issues can be resolved now.

As for removal, the following things need to be done:

(1) The release notes need to be updated to reflect that lilo is no
longer a bootloader option;
(2) The debian-installer team needs to remove the lilo-installer udeb;
(3) The ftpmasters need to remove lilo from unstable (which will be done
using the appropriate bug filing once the above steps are made);
(4) Users need to test grub2 now.


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: