[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582101: debian-installer: boot on raid mdadm fails after installation (raid1 + LVM) "similar superblocks

Package: debian-installer
Version: 20100211
Severity: important

-- System Information:
Debian Release: 6.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i586)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.32+25
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

After installing a Debian/Squeeze with RAID1 and Logical Volumes, the
freshly installed system does not boot.

Error message at first boot:
mdadm  /dev/sdb1 and /dev/sdb appear to have very similar superblocks.
Please zero-superblocks on one of the device. Devices overlap.

System goes to initrd prompt. Not possible to activate RAID1 unit /dev/md0
mdadm always report the same error when activating the RAID1.

system is having a
/boot device on /dev/hda (/dev/hda1)
/dev/sda and /dev/sdb with one primary partition marqued for RAID
/dev/md0 is used as a PV, there is one Volume Groupe vg01 and 3 logical
volumes : /dev/vg01/lvol1-root /dev/vg02-swap and /dev/vg03-home

If I boot the unbootable system with a live CD, I manage to activate the
MD and the LVM on it and do it manually.

Installing a Debian Lenny instead of Debian Squeeze solved the problem.
/dev/hda is on compact flash card 4G
/dev/sda and /dev/sdb are brand new 500Gb Seagate Barracuda 7200.12

Grub boots, but as soon as the system is looking for a root filesystem,
it stops waiting, because the RAID array is not ready.

I tried to force --zero-superblocks on the device /dev/sda and /dev/sdb
from a liveCD but it doesn't change.

It makes the system uninstallable on classical RAID1 configuration with 
separate /boot partition

Reply to: