[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#562398: anna: fails if multiple versions of a udeb in Packages file

On Thu, Dec 24, 2009 at 01:30:04PM +0100, Frans Pop wrote:
> On Thursday 24 December 2009, Frans Pop wrote:
> > So the error is probably the result of anna trying to install the same
> > package twice.
> The exit code of anna was 8, which matches an error during unpack or 
> configure.

I've run into this with a custom installer suite with udebs overriding
those in lenny's main/debian-installer.  My solution at the time was
just to filter the Packages file in net-retriever so that anna was only
given one version of any particular package.  (Ubuntu did something
similar, see [1].)  However, it should probably be fixed in anna or
libdebian-installer itself. :)

Specifically, what happens is that anna unpacks all the packages in one
batch, and then it configures all of them.  But while unpacking another
version of a package while another vesrion is in an
unpacked-but-not-configured state is ok, it's not ok to configure a
package that's already in the configured state.  So if a package is in
the list twice, it fails at the second configure for that package.

I'm trying to better understand anna and libd-i to come up with a
suitable patch...

 [1]: https://bugs.launchpad.net/ubuntu/+source/net-retriever/+bug/234486

John Wright <jsw@debian.org>

Reply to: