[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#575682: installation-reports: successful installation on hercules-emulated s390x

Package: installation-reports
Severity: wishlist

Boot method: card reader
Image version: http://people.debian.org/~fjp/d-i/s390/images/daily/generic/
 dd1843ff2ea2732c1c148827dc004827  initrd.debian
 cb4f3536b61cc24f447c4df6f83612c6  kernel.debian
 ca2e8b612360637f881547617ee76b43  parmfile.debian
 downloaded 2010-03-25

Date: Thu, 25 Mar 2010 15:11:54 -0500

Machine: Fake z/Arch, emulated using hercules 3.07-1
 setup described at http://www.josefsipek.net/docs/s390-linux/hercules-s390.html

Actual machine: Dell Inspiron 4000 (a laptop with a Pentium III in it)

 $ df -Tl | grep '/dev'
 /dev/dasda1   ext4     2366164    621636   1624332  28% /
 /dev/dasdb1   ext4     2366164     69088   2176880   4% /home

 Using whole disks.  For example:

 Disk /dev/dasda doesn't contain a valid partition table
 Note: sector size is 4096 (not 512)

 Disk /dev/dasda: 2461 MB, 2461777920 bytes
 15 heads, 12 sectors/track, 3339 cylinders
 Units = cylinders of 180 * 4096 = 737280 bytes
 Disk identifier: 0xe5e5e5e5

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [O]


1. This is my first successful direct squeeze install on s390.  I tried a
   daily build in February (the daily builds weren't being updated at the
   time, so I assume this was actually a January, 2010 daily build) and
   that produced

     HHCCP007I CPU0000 architecture mode set to ESA/390
     HHCCP011I CPU0000: Disabled wait state
               PSW=000A0000 00000000
     Command ==>

   and did nothing more.  So I was excited to see that this time I received

     HHCCP007I CPU0000 architecture mode set to z/Arch

   which seems to mean the SIGP worked.

The rest of this installation report will be boring: because I have my
notes, I am pointing out the steps that were noticeably slow without a
progress display.  Everything worked great. :)

2. Generating an SSH host key takes a long time.  I wish there was a way
   to bypass this step and use telnet instead.

I ssh'd in with ssh -c blowfish and chose "Start installer" for a simple
install.  The location questions were as I'd expect.

3. Somewhat slow to show the "Choose mirror" list.

4. Somewhat slow after downloading release.

5. As Josef Sipek notes, the installer calls DASDs "Disk access storage
   devices".  That should be "Direct access".

6. "Disks need to be formatted before you can create partitions": it
   isn't clear to me what this means --- partman coped fine without
   this step.  Maybe it would be clearer to be more explicit:
   "Reinitialize partition table?" or something similar would have
   been much clearer (if that is what was meant), though perhaps too
   jargon heavy.

7. Blue screen for a while after "Starting up the partitioner" finishes
   and before I can interact with the partition manager.

8. The partitioner is even nicer than I remember it.  I went with ext4
   for both partitions (might have used btrfs if that was available).

9. It asks if I want to go back and use swap.  IIRC to avoid fragmentation
   over time it is really necessary to have swap.  Is there a suggested
   way to deal with this in emulated environments like this one, where
   swapping to memory would be by far preferrable over doing disk I/O?
   Anyway, I said "no swap" in keeping with Josef's instructions.

10. Installing the base system takes a while.

    I hope there is just a final interview after that before I can walk
    away and let the installer do its thing, but that is not to be.

    man-db triggers take a lot of time.  Maybe they could be saved up
    for the end of the install?

    The progress messages often have the form "Retrieving 1 file of 2".
    This is not very useful, since it doesn't say 1 file of 2 in what

Incidentally, an installer timechart would be kind of neat to play

11. Now comes an interview to set up root and the first user.  There
    was no option to set up sudo here.  (I like to use a dedicated
    "sudoer" user to take advantage of sudo caching credentials but
    timing out appropriately without making my main account so easily
    root-equivalent while I am carrying out administrative tasks.)

12. Configuring APT takes a while.

13. Then "Select and install software" --- this is the bulk of the
    task.  I think man-db triggers make this slower than it needs
    to be.

14. At progress=13%, the popcon dialog comes up.  Couldn't it have
    asked sooner?

15. Eventually it starts up tasksel.  Not much to say about that ---
    it works pretty well.  I chose to install the standard system

16. For the initial boot:

    - starting up the login shell takes a _long_ time (completion
      script cruft)?

    - -bash: no job control in this shell

    - C locale (no non-ASCII characters).  Not sure why.

17. Something strange happened when I suspended reportbug: it seems
    to have accepted a ^C that was meant to be directed at bash.

  Please select a severity level: [normal]
  [1]+  Stopped                 reportbug installation-reports
  jrn@s390:~$ ls /usr/share/doc/insta^C
  jrn@s390:~$ ls /usr/share/bug/installation-reportat^C
  [1]+  Terminated              reportbug installation-reports
  jrn@s390:~$ ls /usr/share/bug/installation-reports
  jrn@s390:~$ ls /usr/share/bug/installation-reports/script
  ^[[Ajrn@s390:~$ less /usr/share/bug/installation-reports/script
  jrn@s390:~$ less /usr/share/bug/installation-report/script
  jrn@s390:~$ fg
  -bash: fg: current: no such job

18. Next step is to install telnet as an inetd service to get rid of some

So, very smooth.  I’m impressed.


Installer lsb-release:
DISTRIB_DESCRIPTION="Debian GNU/Linux installer"
DISTRIB_RELEASE="6.0 (squeeze) - installer build 20100325-05:20"

Installer hardware-summary:
uname -a: Linux s390 2.6.32-3-s390x #1 SMP Thu Feb 25 15:07:55 UTC 2010 s390x GNU/Linux
lspci -knn: pcilib: Cannot open /proc/bus/pci
lspci -knn: lspci: Cannot find any working access method.
lsmod: Module                  Size  Used by
lsmod: dm_mod                 82061  0 
lsmod: md_mod                100992  0 
lsmod: xfs                   615180  0 
lsmod: exportfs                4658  1 xfs
lsmod: ext4                  420316  2 
lsmod: jbd2                  108020  1 ext4
lsmod: crc16                   1471  1 ext4
lsmod: ext3                  154425  0 
lsmod: jbd                    70570  1 ext3
lsmod: vfat                   11890  0 
lsmod: fat                    61179  1 vfat
lsmod: nls_base                8049  2 vfat,fat
lsmod: ext2                   80475  0 
lsmod: mbcache                 8226  3 ext4,ext3,ext2
lsmod: ctcm                   79453  0 
lsmod: fsm                     3674  1 ctcm
lsmod: cu3088                  2368  1 ctcm
lsmod: dasd_eckd_mod          69042  8 
lsmod: ccwgroup                7786  1 cu3088
lsmod: dasd_mod               63773  5 dasd_eckd_mod
df: Filesystem           1K-blocks      Used Available Use% Mounted on
df: tmpfs                   124944        20    124924   0% /dev
df: /dev/dasda1            2366164    621224   1624744  28% /target
df: /dev/dasdb1            2366164     69080   2176888   3% /target/home
df: /dev/dasda1            2366164    621224   1624744  28% /dev/.static/dev
df: tmpfs                   124944        20    124924   0% /target/dev
free:               total         used         free       shared      buffers
free:   Mem:       249888       222908        26980            0        24420
free:  Swap:            0            0            0
free: Total:       249888       222908        26980
/proc/cmdline: ro locale=C
/proc/cpuinfo: vendor_id       : IBM/S390
/proc/cpuinfo: # processors    : 1
/proc/cpuinfo: bogomips per cpu: 171.00
/proc/cpuinfo: features	: esan3 zarch stfle msa ldisp eimm etf3eh highgprs 
/proc/cpuinfo: processor 0: version = 00,  identification = 000069,  machine = 9672
/proc/iomem: 00000000-0fffffff : System RAM
/proc/iomem:   00000000-0035ba37 : Kernel code
/proc/iomem:   0035ba38-0052365f : Kernel data
/proc/interrupts:            CPU0       
/proc/interrupts: EXT:     955097 
/proc/interrupts: I/O:     168569 
/proc/meminfo: MemTotal:         249888 kB
/proc/meminfo: MemFree:           26980 kB
/proc/meminfo: Buffers:           24428 kB
/proc/meminfo: Cached:           167084 kB
/proc/meminfo: SwapCached:            0 kB
/proc/meminfo: Active:            69028 kB
/proc/meminfo: Inactive:         107024 kB
/proc/meminfo: Active(anon):       2016 kB
/proc/meminfo: Inactive(anon):     3920 kB
/proc/meminfo: Active(file):      67012 kB
/proc/meminfo: Inactive(file):   103104 kB
/proc/meminfo: Unevictable:       21376 kB
/proc/meminfo: Mlocked:               0 kB
/proc/meminfo: SwapTotal:             0 kB
/proc/meminfo: SwapFree:              0 kB
/proc/meminfo: Dirty:               368 kB
/proc/meminfo: Writeback:             0 kB
/proc/meminfo: AnonPages:          5952 kB
/proc/meminfo: Mapped:             3184 kB
/proc/meminfo: Shmem:                20 kB
/proc/meminfo: Slab:              19064 kB
/proc/meminfo: SReclaimable:      15800 kB
/proc/meminfo: SUnreclaim:         3264 kB
/proc/meminfo: KernelStack:        1424 kB
/proc/meminfo: PageTables:          256 kB
/proc/meminfo: NFS_Unstable:          0 kB
/proc/meminfo: Bounce:                0 kB
/proc/meminfo: WritebackTmp:          0 kB
/proc/meminfo: CommitLimit:      124944 kB
/proc/meminfo: Committed_AS:      10672 kB
/proc/meminfo: VmallocTotal:    1048576 kB
/proc/meminfo: VmallocUsed:        4088 kB
/proc/meminfo: VmallocChunk:    1039572 kB
/proc/meminfo: HugePages_Total:       0
/proc/meminfo: HugePages_Free:        0
/proc/meminfo: HugePages_Rsvd:        0
/proc/meminfo: HugePages_Surp:        0
/proc/meminfo: Hugepagesize:       1024 kB

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: s390 (s390x)

Kernel: Linux 2.6.32-3-s390x (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash

Reply to: