[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#572803: Module "pata_via" missing from Lenny d-i kernel

Package: debian-installer
Version: 20090123lenny6
Severity: important

My bug report boils down to this:

The "pata_via" module is apparently excluded from the kernel of the Lenny installer.
And I don't know how I could work around that.

The full story:

I tried to install Lenny (5.03) on a machine with an Asrock G965M-S motherboard:

The board has SATA support and a (legacy) PATA IDE controller. I have
a PATA harddisk and DVD drive hooked up to the PATA IDE controller
(since I do not have any SATA drives).

But the Lenny installer can neither find my harddrive nor the DVD
drive. It seems that the PATA IDE controller is not detected or not

The PCI device identifier of the controller is 1106:0415, i.e. vendor
"VIA Technologies, Inc.", device: "PATA IDE Host Controller".

The "pata_via" module seems to support this controller:

But the "pata_via" module is not available in the Lenny d-i kernel. I
can neither modprobe it or locate the *.ko file.

I successfully installed OpenSUSE  on the machine (which detected the
controller and loaded the "pata_via" module).

But I would much rather prefer to install Debian.

-- System Information:
Debian Release: 5.0.4
  APT prefers stable
  APT policy: (900, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-2-686 (SMP w/1 CPU core)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: