[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#568975: [squeeze/lenny][i386][2010-02-04] grub-installer fails, system unbootable

Package: installation-reports

Boot method: network, PXE image
Image version: daily installer 20100204-22:53 (see below)
Date: 2010-02-09

% cat /var/log/installer/lsb-release
DISTRIB_DESCRIPTION="Debian GNU/Linux installer"
DISTRIB_RELEASE="6.0 (squeeze) - installer build 20100204-22:53"

Machine: Dell PE 2950, 2 disks, no h/w raid.
 There are two disks, partitioned identically.
 There are three partitions.
 All the partitions are type 0xFD, ie 'linux raid autodetect'
 They are sized and used as:
 /dev/md0 1 Gb for / (ext3)
 /dev/md1 4 Gb (swap)
 /dev/md2 the rest (LVM container).
 /boot is contained within the / partition.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [o]
Detect network card:    [o]
Configure network:      [o]
Detect CD:              [o]
Load installer modules: [o]
Detect hard drives:     [o]
Partition hard drives:  [o]
Install base system:    [o]
Clock/timezone setup:   [o]
User/password setup:    [o]
Install tasks:          [o]
Install boot loader:    [E]
Overall install:        [E]


I am doing a preseeded install of Lenny, using the Squeeze installer.
I am using this version of the installer so I can preseed s/w raid + LVM.
This used to work, at least it was working in Nov/Dec 2009.

Everything works (great!) up to the point where grub-installer is run.
This fails because the call 'chroot /target /usr/sbin/grub-install' fails.
Tracing the execution there reveals
 - a bug in grub-install, which has already been fixed (#568835)
 - a complaint from grub-probe:
     grub-probe: error: no mapping exists for `md0'
 - a final error message:
     The file /boot/grub/stage1 not read correctly.

The final error seems to be coming from a failure in 'grub --batch'.
I hacked grub-install to show the logfile; it generates output like:

+ /usr/sbin/grub --batch --device-map=/boot/grub/device.map
+ cat /tmp/grubDyCCBC

    GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

   [ Minimal BASH-like line editing is supported.   For
     the   first   word,  TAB  lists  possible  command
     completions.  Anywhere else TAB lists the possible
     completions of a device/filename. ]
grub> dump (hd0,0)/boot/grub/stage1 /tmp/grubWkT2MC
Error 2: Bad file or directory type
grub> quit

See also the output log in the attachments.

It appears grub is partially installed.
If I "continue the install without a bootloader",
everything else in the install sequence seems to work.
But when the system tries to boot I get:

  GRUB loading stage 1.5

  GRUB loading, please wait...
  Error 2
And nothing further.

When I booted GRML and checked the filesystems, /boot/grub
had everything expected in it, except for the menu.lst file.

I tried to fix the system by using grub-install and the grub shell,
in a variety of ways, e.g.
 - preseeding grub-installer/bootdev as (hd0)

 - installer# chroot /target /usr/sbin/grub-install --no-floppy --recheck /dev/sda [1]

 - installer# chroot /target
   target# grub

and so forth. I also tried to use the lenny installer in rescue mode.

None of these attempts worked, for reasons which are obscure to me.
I always get errors like 'Bad file or directory type' or
'Cannot mount selected partition' or 'Cannot find file'.
I now have a system that is installed, but unbootable.
I have not resorted to LILO but I may get that desperate yet.
I have not attempted to use grub2 because AIUI grub2 doesn't support
software raid.
Any advice on how get a bootable system would be welcome.

In attachments.tar.bz2:
   (up to the point where grub-installer initially fails)
   (partman log, up to the same point)
   (output from running [1] above)
   (preseeding file, copied from /var/lib/preseed/log)
 fdisk.sda, fdisk.sdb
   (fdisk output)


Kind regards,

Attachment: attachments.tar.bz2
Description: Binary data

Reply to: