[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#562051: Partman hanging on 52%, Polish language on MD devices

reassign 562051 partman-md
tag 562051 unreproducible moreinfo

I've tried to reproduce this with both a daily image and a Lenny image. 
I've not used the identical disk layout, but I did create 3 RAID devices 
over 2 disks.

On Tuesday 22 December 2009, Marcin Owsiany wrote:
> This is the configuration before starting the installer. The partioning
> program showed all of them as expected.
> The steps to reproduce the problem:
> 1) select Polish language
> 2) in the partitioning tool select /dev/md2
> 3) choose ext3 as the filesystem
> 4) choose "format"
> 5) mount as the root filesystem
> 6) go back to the main menu of the partitioning program

Tried that.

> Now, the behaviour differs slightly depending on what the user wanted to
> do next:

The strange thing is that in neither of the cases below does a progress bar 
appear. And it should not either. There are some actions executed in the 
described situations, but those don't have a progress bar.

> 7a) select another partition ->
> a progress bar appears, immediately goes to 52%, and hangs forever

Here I simply get the configuration menu for the selected partition.

> 7b) select "save changes and continue with the installation" ->
> a progress bar appears, proceeds up to 52%, at which point it hangs
> forever

Here I get the confirmation dialog for finishing the partitioning. Only 
*after* I confirm that do we get a progress bar, but for ext3 that only 
ever goes up to 33%, and not 52%.

AFAICT partman behaves correctly, even in Polish ;-)

Without degugging info from someone who can reproduce the problem there's 
nothing more we can do here.


Reply to: