[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

init fails to boot from loop-aes encrypted raid root fs due: "/dev/md1: no such file"

Hello guys!

I have a problem where I reach the end of my linux competences. 

~~~ This is what I try to accomplish:
Install Debian 5.0.3/AMD64 on a blank system with 3 SATA IDEs
Fully encrypted using loop-aes (mandatory). 
System should be able to start with 1 failed/missing disk

Partition scheme (identical on all 3 discs):
  256MB /boot, ext3 / RAID1 , plain
  4  GB /    , ext3 / RAID5 , loop-aes (key)
  512MB        swap         , loop-aes (tmp)
  1,5TB /srv , ext3 / RAID5 , loop-aes (key)

  /boot    attached via /dev/md0
  /, /srv  attached via loop0,1 ontop of /dev/md1,2

~~~ installation process:
I was very pleased to see loop-aes supported in the expert installater at

My first attemp to install from a USB stick failed as the installer itself
already loads the loop device without loop-aes support code. So I grabbed a
DVD drive and now I'm working with the debian-503-amd64-xfce+lxde-CD-1.iso

~~~ problem:
The system fails to boot and repetingly writes: "/dev/md1: No such file or
directory" (/).

As far as I understand, the init script tries to mount /dev/md1 to / but the
RAID5 has yet not been started prior to mounting the root fs.

During startup I see sth like: 
    < sda found >
    < sdb found >
    < sdc found >
    Begin: Mounting root file system.... /scripts-localtop

What I miss there is the output which says that a RAID has been detected and
initialized (superblocks are all fine).
The installer offered to use a "custom initrd". I tried to reinstall and use
the "generic initrd" without any luck, either.

I tried to inspect the initrd with my limited capabilities and it contains
the gpg key for the root fs and a few init scripts. So this seems to went
fine. I thought maybe I need to include some missing modules but I have no
clue how I would have to rebuild the initrd without the system being up and
running. First of all I have no idea what to change at all :-)

Any hints how I get this system bootable? I will dowloaded Knoppix to get
somehow access at least to the initrd.

Thank you very much for your time and support!
- Ben

Reply to: