[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems with installation from usb-stick / preseeding grub installation device


I'm preseeding d-i boot to install lenny on several (identical) boxes we just got. Since I'm still in the "play with the preseed file and see what's possible"-phase I'm often changing the preseeding file, so I boot from usb-stick. So far it works splendid, many thanks.

However, I have a problem similar to #516280: During installation the usb stick is /dev/sda and the target hard disc /dev/sdb. grub get's installed to the mbr of /dev/sda; grub's menu.lst contains (hd1,0) and the generated fstab refer to /dev/sdb as well. So after the installation, the System is unbootable without the stick.

Since I only want to install to identical systems, I tried to workaround the problem by running a script via preseed/late_command, to fixi fstab and menu.lst in /target. That works (well; it's a dirty hack, but it works), but I fail to get grub installed into the mbr of the hard disc. Grub always ended up in the boot record of the usb-stick (/dev/sda or (hd0)).

I tried to preseed grub-installer/bootdev to enforce installation to the hard disc, but somehow it always get's ignored.

So far I tried the following:

d-i grub-installer/bootdev string (hd1)
d-i grub-installer/bootdev string /dev/sdb
d-i grub-installer/bootdev string (hd1,0)

grub get's always installed to the usb-stick at (hd0) / /dev/sda. I can verify that by looking in /var/log/installer/syslog after the installation:

Dec  2 12:56:19 grub-installer: info: Installing grub on '(hd0)'
Dec  2 12:56:19 grub-installer: info: grub-install supports --no-floppy
Dec 2 12:56:19 grub-installer: info: Running chroot /target grub-install --no-floppy --recheck "(hd0)"

I also looked at /var/log/installer/cdebconf/questions.dat, which contains the following:

Name: grub-installer/bootdev
Template: grub-installer/bootdev
Value: (hd1)
Owners: d-i, grub-installer
Flags: seen
 ID = grub-installer/bootdev

So I guess, that I actually do preseed the variable, but for some reasons it get's ignored.

Has someone an idea what I'm doing wrong? Beside the bootdev I only pressed a grub passwort hash and set grub-installer/only_debian to true (which as I understand only avoids the confirmation of the installation, right?)

Best regards,

Reply to: