[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#558823: /dev/disk/by-uuid not populated in d-i with RAID

Package: installation-reports

I installed to an ARM machine today with the daily image and towards
the installation there was a hang at: "Configuring flash memory to
boot the system: 33%".  Looking at /var/log/syslog showed that
flash-kernel's initramfs hook waited for user input because the UUID
was not found.

"blkid /dev/md1" showed the same UUID that flash-kernel was
complaining about.  Looking at /dev/disk, I noticed that the by-uuid
directory didn't exist at all!

When I did:
| echo change > /sys/block/sda/sda2/uevent
the by-uuid dir was added and the UUID for my swap partitioon showed
up.  However, I couldn't make the UUID of my RAID partition show up
| echo change > /sys/block/md0/uevent

I ran into this bug once before but thought it was a glitch.  But a
few days ago another user reported this issue to me and today I ran
into it again.  Normally I don't use RAID but today I did, so I'm
wondering if it's related to that.

Colin, Md, others: any idea?

Here's a workaround for users who run into this issue: open another
SSH connection to the installer, open a shell and type:
    ps aux | grep -i flash_kernel
then kill that PID.  Then edit the file
and remove the check that ensures the root device exists.  The
installer will continue.  Wait until it reaches
"Installation complete" and hit "Go Back".  Then choose "Make
the system bootable" again.
Martin Michlmayr

Reply to: