[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Corrupt floppy image in archive


> > I think that woody/main/disks-i386/current/images-1.20/root.bin is
> > corrupt. It seems to contain a kernel instead of a compressed root
> > filesystem. Is it possible to fix this?
> >
> > I found this out when I tried to reinstall an old 386 machine. I can
> > attach a 3.5" floppy temporarily to work around this but it would be
> > better to have a working root.bin!
> I don't even know where to begin.
> 	o where did you get it from?  (I'm assuming archive.debian.org
> 	  but that is not at all clear.)

yes, archive.debian.org, but I think it's the same on all mirrors.

> 	o d-a is unlikely to be the correct contact address for things
> 	  like this.  Maybe the ftpmasters feel responsible about this
> 	  particular archive.  But even then, they don't make the
> 	  images.
> 	  Really this question would be more appropriate for
> 	  debian-users or maybe -boot or -project.
> 	o the 1.20 root.bin image was a kernel on the woody iso too. - I
> 	  am not convinced that is wrong.

I managed to find an old Woody DVD where the image is also incorrect.
It must be wrong, since I tried the installation and failed (but definitely
no disk read error). Either it was corrupt from the beginning, or has been
corrupted shortly after the release.

> 	o woody?  seriously?  That's oldoldoldstable.  We can't really
> 	  support that.

I know. But I thought someone might be interested to fix it.

I still have virtual machines with Woody. Is it hard to recreate the
root.bin image oneself? I looked at the root.bin in images-1.44, but
I coudn't get it small enough for 1.2 MB floppies.

Pro-Linux - Germany's largest volunteer Linux support site
http://www.pro-linux.de/          Public Key ID 0x3DDBDDEA

Attachment: signature.asc
Description: Digital signature

Reply to: