[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#512934: installation-reports: no sound at all; worked in Etch, works with Knoppix

Seb <seb@h-k.fr> writes:

>>>>> My only problem, but a very significant one, is that I have absolutely no
>>>>> sound.
>>>>> [...]
>>>>> My sound card is a very common (and oldish) SoundBlaster PCI 128.
>>>>> The correct kernel driver, snd_ens1371, is loaded (lsmod | grep snd).
>>>>> Sound does not work either when I select (via ~/.asoundrc) the
>>>>> motherboard's sound card.
>> I've read another report (#516866) where rerunning alsaconf resolved the
>> issue for the reporter.  It would be interesting to know whether that
>> also helps you.
> I had not tried running alsaconf by hand before.
> alsaconf finds three cards:
> hda-intel	nVidia Corporation MCP65 High Definition Audio (rev a1)
> ens1371		Ensoniq 5880 AudioPCI (rev 02)
> legacy		Probe legacy ISA (non-PnP) chips
> I don't know whether the "legacy" line is normal.

I wouldn't worry, looks like an option you aren't interested in.

> At the end it "fails" with:
> 	amixer: Mixer attach default error: No such device
> It doesn't actually say it failed, since right afterward I see "Now ALSA
> is ready to use." 'amixer' is supposed to adjust the volume I think.
> I tried googling on the error message but no success either.

It may be relevant, I don't know much about alsaconf.

> Just to be on the safe side:
> uid=1000(seb) gid=1000(seb)
> groups=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),111(fuse),114(scanner),1000(seb)
> ~>ls -l /dev/audio
> crw-rw---- 1 root audio 14, 4 Feb 24 12:42 /dev/audio
> ~>ls -l /dev/dsp
> crw-rw---- 1 root audio 14, 3 Feb 24 12:42 /dev/dsp
> ~>id
> uid=1000(seb) gid=1000(seb)
> groups=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),111(fuse),114(scanner),1000(seb)

Good, but /dev/audio and /dev/dsp are the OSS nodes, ALSA have nothing
to do with them.  Look under /proc/asound instead.  But it doesn't
look like a permission problem.  Can you run alsamixer (with the
appropriate -c option to select your cards)?  Try aplay as well (use
-l to list your devices).

Reply to: