[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

networking problems debian-armel-5.0rc2.zip


I recently decided to give Debian ARM a try on my nslu2 using the
latest, debian-armel-5.0rc2.zip. Kudos to all those involved -- very

Here are some the issues I've run into:

First try: reset to Linksys firmware, configure network in full per
my requirements, flash to Debian installer via linksys webgui, install
to Quantum Fireball 3G disk

Issues -- wouldn't recognize the disk in USB port 1 so moved to
USB2, extremely slow install (> 12 hours), my guess is this drive's
performance was just not up to snuff since its so old, and upon reboot
-- pingable but no ssh...even after leaving it sit for a few hours.

Nothing in the logs.

Second try: same disk used, this time not pingable at all

Nothing in the logs eluding to the issue.

Third try: Used a 1G flash stick in port (much faster install! Closer
to the 4 hours but still more like about 6-8hrs)

Issues: unit came up fine, made many of the suggested modifications for
removing unneeded modules, installed ntpdate, adjusted fstab to reduce
writes to flash....

After reboot, the unit loads, NIC stays up, but as soon as it mounts
the flash stick, the ethernet goes down and I never get network
connectivity nor see the LED become lit. I see nothing in the logs that
its even attempted booting up

I followed instructions to remove hotplug from interfaces and ensured
auto eth0 is present, made sure the symlink was present, and reviewed
fstab -- which ended up being changed to the below -- why I do not
know, nor if it is remotely correct with the UUID it chose. I've tried
going back to what I thought was in my original fstab with no success
as well as removed fsck check and still no love.

Can anyone advise what might be amiss here? Or should I try being a bit
more patient and leave it sit a few hours?

Thanks for the help! Keep up the good work!

Here is what I noted my fstab had been modified to upon rebooting...

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda1
UUID=16bfd604-a255-438b-af3f-c786ff8ac85f /               ext3
relatime,errors=remount-ro 0       1 # /dev/sda5
UUID=4cb02dee-d46e-42ff-b112-f6d0f2e3484d none            swap
sw              0       0 /dev/scd0       /media/cdrom0   udf,iso9660
user,noauto,exec,utf8 0       0

Reply to: