[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#508157: debian-installer: Rescue mode: cryptsetup doesn't accept password (verified correct, muliple x)

Package: debian-installer
Severity: normal

Using the lenny-rc1 xfce-cd1 image I attempted to use rescue mode to operate on an encrypted lvm which is detected and mounts fine with the regular boot system.  It was created using a previous version of lenny's installer (but I don't remember which one).

I suspect the problem may be related to the fact that when I initially created the filesystem there was a usb key drive in the system.  OTOH I have tried rescue mode both with and without the key to no avail.

It may matter that I have modified crypttab to use /dev/disk/by-uuid/the-uuid-of-the-luks-partition and that the name of the crypt volume has been changed from the default.

I have tried with luksOpen /dev/disk/by-uuid/uuid-of-luks crypt_name and get a message which states that cryptsetup failed because there was no key with the entered password, however I have entered the password multiple times.

Could it matter that it is a logitech internet keyboard and not a plain vanilla keyboard?

Please let me know what other information I can send that would help.



-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: