[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installation-report: no keyboard on first boot

Installation attempt through AMD64 netinst CD, 20081117-09:40 edition on an "early 2008" MacBook Pro, 15".

Smooth install, with a manual exception (through secondary console) of using gptsync prior to LILO installation as documented on http://wiki.debian.org/MacBook. It may have worked without, I just played it safe.

Partition info: all on sda3, configured as an LVM volume. Separate /boot (ext2), / (ext3), /home (encrypted ext3) and encrypted swap.

Booting through rEFIt, then LILO, then normal bootsequence that stops prompting for password at the swap mount step, as expected. Keyboard not responding at this step. More accurately, enter key does nothing (other keys are expected to be silent).

Keyboard detected as "PC-style (AT/PS2)" during installation.

Debugging performed:
- No external USB keyboard available for testing
- Keyboard working OK in LILO menus
- tried with lilo command line "Linux noapic irqpoll acpi=force", per hints on http://wiki.debian.org/MacBook. Same situation (is this the right way to supply boot arguments through Lilo ? Haven't used it for a long time). - no "shift-pageup" combination working that I know of, to inspect boot log; no access to dmesg at that stage

The only thing I can think of is that I selected the "this system only" initrd generation option. Is there a way to change this without fully reinstalling ?

Assistance appreciated.



Reply to: