[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#504721: Console broken on debian-installer on Sparc LDOM

Package: rootskel
Version: 1.69
Severity: important

Hi rootskel maintainers :)

I've been trying to get debian-installer (lenny) working on a Sun LDOM
(i.e., SPARC, sun4v).  I'm having some trouble, though.  When the
installer boots, you get a mono console, and the arrow keys, tab, and
enter don't do as expected (enter scrolls down the screen, tab does a
tab, etc) rather than moving through the menu.

I booted with BOOT_DEBUG=3 to pin down where this is happening.
Looking at /etc/inittab, first, debian-installer-startup is run.  I
run this and the console still behaves normally.  When I run the
second script, debian-installer, the menu launches and my keyboard
doesn't drive the menu any more.

Theres some discussion on why this might be happening and methods I've
tried on debian-boot (Frans Pop has been very helpful!), and it looks
like it may be something to do with reopen-console.  I'm not an expert
on the console though, so there may be something I've missed.  As the
scripts are run via reopen-console then sourced (debian-installer
being a wrapper round a bunch of sourced scripts), I'm unable to
recreate the exact environment.  If I don't use reopen-console and I
run debian-installer from the shell on my own, it works as expected.

I've raised this bug on Frans' recommendation, and the thread on
debian-boot is here:

I'm happy to try out any recommendations you have on this kit while I
still have it (its try-n-buy, its actually a Sun T6230 blade).

Many thanks,


Reply to: