[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#456154: marked as done (debian-installer: amd64 re-boot fails due to missing /etc/crypttab)

Your message dated Tue, 05 Aug 2008 17:17:02 +0000
with message-id <E1KQQ9e-0004sV-8O@ries.debian.org>
and subject line Bug#393728: fixed in partman-md 42
has caused the Debian Bug report #393728,
regarding debian-installer: amd64 re-boot fails due to missing /etc/crypttab
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

393728: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=393728
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Severity: important

Hi there,

while trying to install debian I encountered the problem that the
installed system was unbootable. 

The setup I tried is a md setup with everything crypted except /boot

This was reproducible with debian-40r1-amd64-CD-1.iso and unofficial
netinst cd from kmuto (because of ICH9 chipset and e1000 support, my
disks/cdrom are detected properly with the official cd's)

Here is the way I tried to install

1) Partition the disks
	/dev/sda1	=>	256MB
	/dev/sda2	=>	rest of disk
	/dev/sdb1	=>	256MB
	/dev/sdb2	=>	rest of disk
2) Set partition type to raid autodetect for all of the above
3) Setup raids
	/dev/md0	=> 	[ sda1, sdb1 ]
	/dev/md1	=>	[ sda2, sdb2 ]
4) Choose /dev/md0 as ext3 which should be mounted on /boot
5) Choose /dev/md1 as target for a crypted disk (refered as
/dev/mapper/crypt for the rest of this text)
6) Setup LVM with /dev/mapper/crypt as physical disk
	vg00 => /dev/mapper/crypt
	lvol-root	2GB 	/
	lvol-swap	8GB	swap
	lvol-usr	8GB	/usr
	lvol-var	8G	/var
	lvol-home	16GB	/home
7) Happily install debian on it. Works all fine until I try to boot
into the just installed system. There it hangs with (something
similiar to)
	vg00-lvol-root not found	
	vg00-lvol-root not found	
	Waiting for root filesystem
until it drops into a busybox shell. Disks are detected before, since
I got the message from md that md1 is not synchronized.

Doing the same like above just change / to be on md0 instead of the
crypted volume the system boots at least into single user mode.
Examining the install I found out that there was only an empty
/etc/crypttab, adding the entry for /dev/md1 manually I could mount
all the devices and then the system boots normally.

>From above I conjecture that also the failed try with / on the crypted
device was due to a missing crypttab.

Sitz der Gesellschaft / Corporate Headquarters:
Deutsche Lufthansa Aktiengesellschaft, Koeln
Registereintragung / Registration:
Amtsgericht Koeln HR B 2168

Vorsitzender des Aufsichtsrats /
Chairman of the Supervisory Board:
Dipl.-Ing. Dr.-Ing. E.h. Juergen Weber

Vorstand / Executive Board:
Wolfgang Mayrhuber (Vorsitzender / Chairman)
Stephan Gemkow
Stefan Lauer

--- End Message ---
--- Begin Message ---
Source: partman-md
Source-Version: 42

We believe that the bug you reported is fixed in the latest version of
partman-md, which is due to be installed in the Debian FTP archive:

  to pool/main/p/partman-md/partman-md_42.dsc
  to pool/main/p/partman-md/partman-md_42.tar.gz
  to pool/main/p/partman-md/partman-md_42_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 393728@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Otavio Salvador <otavio@debian.org> (supplier of updated partman-md package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Tue, 05 Aug 2008 14:01:00 -0300
Source: partman-md
Binary: partman-md
Architecture: source all
Version: 42
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Otavio Salvador <otavio@debian.org>
 partman-md - Add to partman support for MD (udeb)
Closes: 391474 391479 391483 393728 398668
 partman-md (42) unstable; urgency=low
   [ Jérémy Bobbio ]
   * Clean up the initialization of MD devices.  Together with the changes
     introduced in partman-base (>= 124), setup of RAID devices won't be lost
     across partman restarts anymore.
     (Closes: #391479, #391483, #393728, #398668)
   * Load the necessary modules and scan RAID arrays during partman
     initialization.  (Closes: #391474)
   * Add device_remove_md() in lib/md-remove.sh: it is necessary to allow
     proper removal of MD devices when we create a new label on a disk
     (for example, during automatic partitioning).
   [ Updated translations ]
   * Arabic (ar.po) by Ossama M. Khayat
   * Belarusian (be.po) by Pavel Piatruk
   * Bulgarian (bg.po) by Damyan Ivanov
   * Czech (cs.po) by Miroslav Kure
   * German (de.po) by Jens Seidel
   * Dzongkha (dz.po) by Tenzin Dendup
   * Esperanto (eo.po) by Felipe Castro
   * Spanish (es.po) by Javier Fernández-Sanguino Peña
   * Basque (eu.po) by Piarres Beobide
   * Finnish (fi.po) by Esko Arajärvi
   * French (fr.po) by Christian Perrier
   * Galician (gl.po) by Jacobo Tarrio
   * Gujarati (gu.po) by Kartik Mistry
   * Croatian (hr.po) by Josip Rodin
   * Indonesian (id.po) by Arief S Fitrianto
   * Italian (it.po) by Milo Casagrande
   * Japanese (ja.po) by Kenshi Muto
   * Korean (ko.po) by Changwoo Ryu
   * Lithuanian (lt.po) by Kęstutis Biliūnas
   * Malayalam (ml.po) by Praveen|പ്രവീണണ്‍ A|എ
   * Marathi (mr.po) by Sampada
   * Norwegian Bokmål (nb.po) by Hans Fredrik Nordhaug
   * Dutch (nl.po) by Frans Pop
   * Portuguese (Brazil) (pt_BR.po) by Felipe Augusto van de Wiel (faw)
   * Portuguese (pt.po) by Miguel Figueiredo
   * Romanian (ro.po) by Eddy Petrișor
   * Russian (ru.po) by Yuri Kozlov
   * Slovak (sk.po) by Ivan Masár
   * Slovenian (sl.po) by Matej Kovacic
   * Swedish (sv.po) by Daniel Nylander
   * Thai (th.po) by Theppitak Karoonboonyanan
   * Tagalog (tl.po) by Eric Pareja
   * Turkish (tr.po) by Mert Dirik
   * Vietnamese (vi.po) by Clytie Siddall
   * Wolof (wo.po) by Mouhamadou Mamoune Mbacke
   * Simplified Chinese (zh_CN.po) by Kov Chai
 770749f26037a6d1ad2df646c87fd0512c9e855a 827 partman-md_42.dsc
 8ec5cbce3911730f6adc306ce50ef743371ef0ea 57654 partman-md_42.tar.gz
 d0ced36ad2a86103020551a42009086302c6a97e 33210 partman-md_42_all.udeb
 c3730404a20f8f37a1a44c34ec8934701a5bc2740fb5e472e00f8e2996662c91 827 partman-md_42.dsc
 8ce19e4ce278dde73a09f511bfff7659fff5e2642da97f44f678233df0bdd5c1 57654 partman-md_42.tar.gz
 33d69590e7b3232146014872e6e6cbd46f0b13091a92a255fdcba9779926928b 33210 partman-md_42_all.udeb
 df412e7bbc176d10e3b19a28b80a162a 827 debian-installer standard partman-md_42.dsc
 c6e25adab9e425eb5bd50d51a19cba45 57654 debian-installer standard partman-md_42.tar.gz
 51c4e5ce28dc2d6da0884a23cb801afe 33210 debian-installer standard partman-md_42_all.udeb
Package-Type: udeb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: