[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#492051: Lenny Beta 2 installer failure

And now I have managed to get a workable install, using a USB stick. However, even this is not easy. If there's a standard way around this problem, perhaps someone can let me know. The problem is that the installer regards the USB memory stick as /dev/sda. This is the first hard disc in the system, as there weren't any IDE discs in the system. Consequently, when grub comes to set things up (devices.map and menu.lst) its idea of the device names is wrong for the reboot scenario when the USB stick is no longer there. The first install I tried failed because of this, indeed, I think GRUB wrote the MBR back onto the USB stick so the stick had to be recreated as well. Second time, I worked around this to some extent by editing these two files and also removing the USB stick before GRUB could write on it. Even so, at boot time, the system couldn't find its swap, which was still wrongly labelled (as /dev/sdb5). Fortunately, you get a chance to change this so I could boot the system. I then searched for all instances of file containing /dev/sdb5. There are two text files whose names I have now forgotten, as well as /etc/fstab but also the name seems to be inside the kernel and some other binary files. Even after changing all the text files, a reboot still wanted to get the wrong swap. This system was using the 2.6.24 kernel, but after an upgrade the 2.6.25 kernel appeared. The grub-update process again screwed up and put /dev/sdb everywhere in menu.lst (I would love to know where it got this name from, as it wasn't in any text file on the system other than installation logs). But, I fixed menu.lst to refer exclusively to /dev/sda instead, after which a reboot using the 2.6.25 kernel worked without incident. I haven't tried rebooting back into the 2.6.24 kernel.

I would like to put the IDE disc back into the system, but I don't think I can, as I expect the system will assign it to be /dev/sda (AFAICS 2.6.25 no longer uses /dev/hd devices at all), and I won't be able to boot the system. Is there any way to get around this automatic assignment of hardware to devices, and in particular to force the device from which I'm going to boot to have a fixed name in /dev?

Jon Thackray
+44 1223 572299
+44 7803 017991

Reply to: