[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#475223: How to disable dma on the netinst CD

Package: debian-installer
Version: 20070308etch2

At least I think that's the correct version. It's the netinst http://cdimage.debian.org/debian-cd/4.0_r3/i386/iso-cd/debian-40r3-i386-netinst.iso

I am trying to use the debian net installer to install debian etch onto a CF card in an CF-IDE converter.

I used to have an old BSD firewall here - on a 64Mb SanDisk card. The net installer can write to this just fine - but - it is too small.

So - I grabbed Kingston 1Gb card. This is giving me dma_timeout_errors. I believe this to be because the newer CF card supports DMA but not the CF-IDE converter (although I'm not sure).

Now - this is a firewall. DMA is absolutely not required.

I have disabled DMA in the BIOS, I have set the PIO level to 3.

At boot I have tried the following

expert nodma
expert ide=nodma
expert hda=nodma

In all cases - I get dma timeouts.

In addition - I can no longer mount the CD-ROM.

If I simply pop the card out and put the sandisk back in the timeouts disappear and the CD-ROM mounts just fine - just that I run out of space installing the base package set.

Any hints on what I should be passing to disable DMA totally would be very much appreciated.

If it can't be done at the start but can be done at the busybox prompt before continuing then this would also be very helpful.


Reply to: