[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#163502: marked as done (cp doesn't detect loops)



Your message dated Mon, 24 Mar 2008 14:21:40 +0100
with message-id <200803241421.41990.thijs@debian.org>
and subject line recent versions fixed this
has caused the Debian Bug report #163502,
regarding cp doesn't detect loops
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
163502: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=163502
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: busybox
Version: 0.60.4-1

If I've got a directory with a file and an empty directory, and try to
do cp * foo/ (foo being the directory), the fileutils/coreutils cp will
say

cp: omitting directory "foo"

whereas the busybox cp will happily loop around and around, creating
foo/foo and foo/foo/foo and so on.


Regards,
Martin



--- End Message ---
--- Begin Message ---
Version: 1:1.9.2-1

Hi,

I've tried to reproduce the behaviour you report on recent busybox versions, 
but they behave just like the normal cp. I therefore think it's safe to 
assume that the bug has been fixed, and I'm hence closing this report. Thanks 
for your help!


Thijs

Attachment: pgpTRAHPFS8My.pgp
Description: PGP signature


--- End Message ---

Reply to: