[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#461336: Debian on Amiga 2000

Package: installation-reports
Severity: normal


Debian-installer-version: Sarge official m68k CD
uname -a: Linux nacho 2.4.27-amiga #1 Tue Aug 30 12:35:11 CEST 2005 m68k GNU/Linux
Date: 2008-01-11

Booted with StartInstall_clgen, slightly modified (added bootloader option to pass
a different memory map to the kernel as one of my memory expansion cards does not
work properly under Linux, and booted into init=/bin/sh to set up a swap partition
before going into the installer.

Machine: Amiga 2000
Processor: 68040, running at 33 MHz
Memory: 16MiB on the CPU card, 6 MiB as Z2 RAM (currently unused), 1MiB CHIP RAM
Root Device: SCSI disk, 2 GB
Root Size/partition table:

Disk /dev/sda: 3 heads, 171 sectors, 8239 cylinders, RDB: 0
Logical Cylinders from 2 to 8238, 262656  bytes/Cylinder 

   Device  Boot Mount   Begin      End     Size   Pri  BBlks    System
/dev/sda1    *    *         2      514   131584     0      0  Amiga FFS Int.
/dev/sda2                 515     1026   131328     0      0  Linux swap
/dev/sda3         *      1027     2050   262656     0      0  Linux native
/dev/sda4                2051     6146   1050624     0      0  Linux native
/dev/sda5                6147     6658   131328     0      0  Linux native
/dev/sda6                6659     8238   405270     0      0  Linux native

Output of lszorro:
00: 07e1:0b:30 Great Valley Products GForce 040 [Accelerator and SCSI Host Adapter]
01: 07e1:ff:00 Great Valley Products GForce 040 [Accelerator]
02: 0877:0b:00 Village Tronic Picasso II/II+ RAM [Graphics Card]
03: 0877:0c:00 Village Tronic Picasso II/II+ [Graphics Card]
04: 03f2:03:00 Microbotics 8-Up (Rev A) [RAM Expansion]
05: 03f2:04:00 Microbotics 8-Up (Rev Z) [RAM Expansion]
06: 0877:c9:00 Village Tronic Ariadne [Ethernet Card and Parallel Ports]

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]

Ran out of memory, I had to reduce the ramdisk_size parameter and set up a swap
device before I could start the installer

Configure network HW:   [O]

Autodetection did not work, I had to manually select the appropriate kernel module

Config network:         [E]

Worked in the first attempt, but failed during the real installation run.

Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [-]

There is no standard boot loader that can be installed from within Linux.

Reboot:                 [O]


Went really well for an installation on a system with only 16 MiB of (usable) RAM.
It might be worthwhile to have a way of setting up some swap device before
starting the full installer, so this can be done without any init=/bin/sh trick.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.21-rc4 (SMP w/1 CPU core)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: