[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#446896: debian-installer: does not detect pci network cards

Package: debian-installer
Severity: normal

I have tried to install this week's build of lenny on a Dell 'Optiplex 
GX1' which has I believe, a custom motherboard made by Dell. This mobo 
has onboard ethernet. I also have two PCI ethernet cards which 
connect via a PCI-to-ISA bridge.

When I tried to install lenny I was unable to configure the network at 
all. This is because the installer could not install a driver for the 
onboard nic (it said 'could not detect any network card, but also 
suggested to try the driver for a National Semiconductor 8390, which 
didn't work). It also failed to detect the PCI cards.

When I tried the same thing using stable 'etch', it managed to load a 
driver for the onboard card, which it detected as a National 
Semiconductor DP83815 (MacPhyter). However the network still didn't 
work. But the installer also detected the PCI cards, which did work to 
get the network up and running. 

I think the onboard network adapter may be broken. However there seem to 
be two failures of the lenny installer here, where the etch installer 
succeeded: the failure to correctly identify the onboard card, and the 
failure to detect at all the PCI cards. Perhaps these are due to support 
for 'obsolete' hardware being removed from the installer? In any case 
perhaps someone can find out why these happened by seeing the difference 
in behaviour from etch, and maybe fix it if it's considered important. 

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18jack1
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)

Reply to: