[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#441446: Swap partition problem with low memory "expert" floppy install

On Tue 02 Oct, Jérémy Bobbio wrote:
> On Sun, Sep 09, 2007 at 09:05:36PM +0000, Chris Bell wrote:
> >    I then attempted to install a second system on hdb plus hdc, with swap
> > plus a single RAID 1 partition on each disc. I tried several times with
> > similar parameters, and each time the swap partition on every one of the
> > three discs was displayed by Partman but the error message later said that
> > there was no swap available and the installation failed.
> Was the message one which follows?
>   No swap partition found; userspace software suspend will not work
>   Currently userspace software suspend can write only to a swap
>   partition.  Your system doesn't seem to have such a partition. Please
>   make one, preferably with twice the size of your physical ram. Then
>   run dpkg-reconfigure or setup the configuration file yourself.
> In this case, you have been bitten by #427104 [1], which is a bug in the
> uswsusp package.  This bug is going to be fixed in the next Etch point
> release.
> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=427104
> Cheers,

   Yes that was part of the problem, but I also failed to install Etch in
"expert" mode starting from both the most recent set of floppies and from
CD, both in low memory mode (64M RAM) and with 128M RAM, the point of
failure always being somewhere around setting up the printing system, just
before the first re-boot, although I did manage to get past the re-boot, but
it failed to complete the boot.
   A simple auto installation (just started by pressing return) just worked.
   I have installed many debian systems, but this was my first series of
attempts to install 4.0r1 and I still do not understand what was causing the
failures. I used both uk.debian.org direct, and a local apt-cacher as proxy,
as well as a CD built using jigdo, burned and verified immediately before
use, with a brand new DVD drive.
   I wanted to test what would happen if I physically moved one of a RAID1
pair between IDE cables, starting with one connected as primary slave and
the other as secondary master, ending with both connected via the secondary
   I first tried to install a simple system on the first of three identical
drives (primary IDE master) in expert mode, and after repeated failures
installed the basic system in auto mode, which just worked. The swap
partition was visible to other later installations, but in every case I
created a swap partition on every drive.
   I then tried to install a simple basic system (base system plus desktop)
on the second and third drives, with single LVM on RAID1. After several
failures I tried just / on RAID1, but this also failed.
   I then spent some time trying to figure out why a simple installation in
expert mode gave repeated failures, but did not achieve any repeatable
   The most likely cause that I could find was that some files had been
upgraded or replaced during security updates, and the installer was
downloading files which did not match the specifications.

Microsoft sells you Windows ... Linux gives you the whole house.
Chris Bell

Reply to: