[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#444807: Etch installer does not detect my hard disks but Woody detected them

Package: installation-reports

Boot method: floppy
Image version:
Date: September 30 2007

Machine: Tiny desktop (Tiny is the name of the manufacturer)
Processor: Intel Pentium II Deschutes
Memory: 256MB SDRAM
Output of fdisk -l (from Woody)

Disk /dev/hda: 128 heads, 63 sectors, 787 cylinders
Units = cylinders of 8064 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1       786   3169120+   b  Win95 FAT32

Disk /dev/hdb: 128 heads, 63 sectors, 589 cylinders
Units = cylinders of 8064 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1        31    124960+  82  Linux swap
/dev/hdb2   *        32       589   2249856   83  Linux

Output of cat /proc/partitions (from Woody)

major minor  #blocks  name

   3     0    3173184 hda
   3     1    3169120 hda1
   3    64    2374848 hdb
   3    65     124960 hdb1
   3    66    2249856 hdb2

Output of lspci -nn and lspci -vnn:
lspci is not found when booting from Woody rescue.bin or Etch boot.img.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [ ]
Configure network:      [ ]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [E]
Partition hard drives:  [ ]
Install base system:    [ ]
Clock/timezone setup:   [ ]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [ ]


I ran Woody very successfully on my desktop computer as above, but with only
64MB RAM, for four years, until Woody got broken during an attempted upgrade
to Etch.  I have been unable to repair Woody, so have used the Woody
rescue.bin and root.bin floppies to move the contents of my home directory
to the Windows drive, ready for a clean install of Etch.  But the Etch
installer floppies completely fail to detect my hard drives, even though
there was never any problem detecting them with Woody.  When I first ran the
Etch installer, it went into low memory mode, so I upgraded my memory from
64MB to 256MB, hoping that that would enable the Etch installer to detect
the hard drives.  The memory upgrade went perfectly, and the Etch installer
no longer goes into low memory mode, but it still does not detect the hard
drives.  The Etch installer boots up, and I go through the steps to where it
starts a shell, and says that the hard disks will be in the /target
directory.  But there is no /target directory.

Before I upgraded my memory from 64MB to 256MB, I could read the boot
messages by using shift + PageUp, but this was no longer possible after the
memory upgrade.  However when I tried the version of the Etch
Debian-Installer built with syslinux from Sarge, I could again read the boot
messages, and they look similar to what I remember from before the memory
upgrade.  I wrote down the messages that looked relevant using pen and
paper, and have retyped them below.  ... indicates lines I have omitted
because they don't look relevant.  I am sending this from Windows Outlook
Express, so lines may get wrapped incorrectly.

ACPI: PM-Timer IO Port: 0x408
Allocating PCI resources starting at 20000000 (gap: 10000000:efff0000)
ACPI: Core revision 20060707
ACPI: Setting ELCR to 0200 (from 0e00)
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfdb91, last bus = 1
PCI: Using configuration type 1
Setting up standard PCI resources
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [NRTH] (0000:00)
ACPI: Assume root bridge [\_SB_.NRTH] bus is 0
* Found PM-Timer Bug on the chipset.  Due to workarounds for a bug,
* this clock source is slow.  Consider trying other clock sources
PCI quirk: region 0400-043f claimed by PIIX4 ACPI
PCI quirk: region 0440-044f claimed by PIIX4 SMB
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 *9 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0,
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: Power Resource [IDEP] (off)
ACPI: Power Resource [IDES] (off)
ACPI: Power Resource [GFAN] (on)
PCI: Using ACPI for IRQ routing
PCI: If a device doesn't work, try "pci=routeirq".  If it helps post a
pnp: 00:01: ioport range 0x400-0x43f could not be reserved
PCI: Bridge: 0000:00:01.0
        IO window: 8000-8fff
        MEM window: efd00000-efefffff
        PREFETCH window: e5b00000-e7bfffff
VFS: Disk quotas dquot_6.5.1
Limiting direct PCI/PCI transfers.
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
00:0a: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:0b: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
ACPI: (supports S0 S1 S5)
Freeing unused kernel memory: 256k freed
Time: tsc clocksource has been installed.
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077

There is absolutely nothing in the boot messages about any of the hard disk
drives.  In contrast to this, here are what appear to be the relevant boot
messages when I boot up using the old Woody rescue.bin and root.bin
floppies.  These messages were again written down from the screen (viewed
with shift + PageUp and shift + PageDown) using pen and paper, then retyped

Starting kswapd v 1.5
Serial driver version 4.27 with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
Real Time Clock Driver v1.09
RAM disk driver initialized: 16 RAM disks of 16384K size
loop: registered device at major 7
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda: DMA, hdb: DMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc: DMA, hdd: pio
hda: ST33210A, ATA DISK drive
hdb: WDC AC22400L, ATA DISK drive
ide0 at 0x1f0-0x1f7, 0x3f6 on irq 14
ide1 at 0x170-0x177, 0x376 on irq 15
hda: ST33210A, 3098MB w/256kB Cache, CHS=787/128/63
hdb: WDC AC22400L, 2319MB w/256kB Cache, CHS=589/128/63
hdc: ATAPI 24X DVD-ROM drive, 256kB Cache
Uniform CD-ROM driver Revision: 3.11
Floppy drive(s): fd0 is 1.44M
Partition check:
    hda: hda1
    hdb: hdb1 hdb2

The following post seems to suggest that the problem might be corrected by
replacing the 2.6.18 kernel with the 2.6.22 kernel:


See also:


However I have tried all Etch or later versions of debian-installer I can
find, including the September 30 '07 daily image, and none detect my hard
disks, which are detected with no problems by the Woody rescue floppies.

Best regards,
Chris Austin

Reply to: