[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#443067: Broken package: Depends: libpcre3 (>= 4.5) but it is not installable

Package: libglib2.0-udeb
Version: 2.14.1-2
Severity: serious
Tags: d-i


Quoting the glib2.0/2.14.1-2 changelog:

   * debian/control.in,
     + Build against the system PCRE instead of the supplied one.

This change broke the udeb produced by glib2.0, as it now depends on libpcre3
which is not currently available in the debian-installer environment.

(Note: it would have been better to notice such issue before uploading
the new package, as daily builds of the debian-installer will now
be broken until the issue is solved.)

Here's the possible solutions discussed with Loïc Minier on IRC:

 * Use glib's internal copy of libpcre to build the udeb

   This have the advantage of keeping the dependencies as they
   previously were, and limiting the numbers of udebs needed by the

   The downside is that the two builds could have an independant set of

 * Ask Mark Baker to add an udeb to libpcre and binNMU glib after that

   The advantage is that glib will not have to be built twice and that
   the behaviour should stay similar in a normal system and in the
   debian-installer environment.

   The downside is that pcre currently have 3 RC bugs, and that it will
   add another source of migration headache to d-i release managers and
   the release team.

Jérémy Bobbio                        .''`. 
lunar@debian.org                    : :Ⓐ  :  # apt-get install anarchism
                                    `. `'` 

Attachment: signature.asc
Description: Digital signature

Reply to: