[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#440161: wrong /etc/fstab when installing on RAID using Adaptec 2100S

Package: debian-installer
Version: 20070308

I recently used d-i to install etch on a FujituSiemens Primergy F200. That maschine has 6 SCSI-Drives built-in, which i have configured as RAID5 (no Hotspare) using the Adaptec-BIOS. During POST and installation the RAID-Array is shown as /dev/sda.

Then i have created a ext3-Partition /dev/sda1 for /boot and a LVM on /dev/sda5 using the rest of the Array-capacity for /.

Installation proceeded fine.

After rebooting the maschine, everything worked fine. System found LVM and could mount it correctely, but then failed to mount /boot (which is on /dev/sda1 - as i thought).

I found out, that for the Adaptec 2100S the modules i2o-core and i2o-block are loaded. The modules find the Adapter correctely.

But my /boot-partition - formerly known as /dev/sda1 - could now be found at /dev/i2o/hda1 after loading the i2o-modules.

After changing the line in /etc/fstab from
/dev/sda1	/boot [...]
/dev/i2o/hda1	/boot [...]
and rebooting the maschine - it worked!

Dont know, if that is a problem in d-i or in i2o...

Reply to: