[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#421352: marked as done (nic-usb-modules should depend on core-modules)

Your message dated Thu, 14 Jun 2007 16:02:02 +0000
with message-id <E1Hyrlq-0008Ca-J8@ries.debian.org>
and subject line Bug#421352: fixed in kernel-wedge 2.37
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: kernel-wedge
Version: 2.34
Severity: important

I get the following, which I believe means that nic-usb-modules needs
an update:

|         kernel-wedge copy-modules 2.6.20-1 iop32x 2.6.20-1-iop32x
|         kernel-wedge find-dups 2.6.20-1-iop32x
| debian/nic-usb-modules-2.6.20-1-iop32x-di lib/modules/2.6.20-1-iop32x/kernel/drivers/base/firmware_class.ko
| debian/core-modules-2.6.20-1-iop32x-di lib/modules/2.6.20-1-iop32x/kernel/drivers/base/firmware_class.ko
| some modules are in more than one package
| command exited with status 1
... and then the same for nic-modules.

This works for me, but I guess core-modules might have to be added as
a dependency to some more packages:

Index: package-list
--- package-list	(revision 46614)
+++ package-list	(working copy)
@@ -10,7 +10,7 @@
  Debian system.
 Package: nic-modules
-Depends: kernel-image, nic-shared-modules
+Depends: kernel-image, nic-shared-modules, core-modules
 Priority: standard
 Description: Common NIC drivers
  This package contains common NIC drivers for the Linux kernel.
@@ -297,7 +297,7 @@
  This package contains common PCMCIA drivers for the Linux kernel.
 Package: nic-usb-modules
-Depends: kernel-image, nic-shared-modules, usb-modules
+Depends: kernel-image, nic-shared-modules, usb-modules, core-modules
 Priority: standard
 Description: USB NIC drivers
  This package contains USB network adapter drivers for the Linux kernel.

Martin Michlmayr

--- End Message ---
--- Begin Message ---
Source: kernel-wedge
Source-Version: 2.37

We believe that the bug you reported is fixed in the latest version of
kernel-wedge, which is due to be installed in the Debian FTP archive:

  to pool/main/k/kernel-wedge/kernel-wedge_2.37.dsc
  to pool/main/k/kernel-wedge/kernel-wedge_2.37.tar.gz
  to pool/main/k/kernel-wedge/kernel-wedge_2.37_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 421352@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated kernel-wedge package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 04 Jun 2007 15:21:30 -0400
Source: kernel-wedge
Binary: kernel-wedge
Architecture: source all
Version: 2.37
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 kernel-wedge - udeb package builder for Debian-Installer
Closes: 421352
 kernel-wedge (2.37) unstable; urgency=low
   [ Martin Michlmayr ]
   * Make nic-modules depend on core-modules. Closes: #421352
   [ Joey Hess ]
   * Split wireless modules out of nic-extra-modules into nic-wireless-modules.
     This new package will contain wireless modules that arn't USB or pcmcia;
     those stay in their respective packages.
   * nic-pcmcia-modules now depends on nic-wireless-modules instead of
   * Add zd1211rw to nic-usb-modules, and ipw2100 and ipw2200 to
     nic-wireless-modules. These had been left off due to needing nonfree
     firmware, but maybe we'll work out a way to provide that, and users can
     always provide it on their own, so I think including these in d-i is
   * nic-usb-modules now depends on nic-wireless-modules for 80211 modules.
 8109c2b32db2cc4047650166f14defb9 670 utils optional kernel-wedge_2.37.dsc
 cce3ca492ca5162a6121a3ee5781d25e 36592 utils optional kernel-wedge_2.37.tar.gz
 18642525870f6f61cb6579eb6d9b4bf7 41460 utils optional kernel-wedge_2.37_all.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: