[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Etch test (was: Simplified booting of Debian install CD on IBM PowerPC servers - Suggestion)

>>The Debian PowerPC install CD (3.1r5) currently only allows booting via
>>Open Firmware on IBM servers. That is typically a very painful method for
>>those that are not well-versed in Open Firmware. I have added the fixes
>>below that will allow the CD to be booted directly from the SMS menus or by
>>pressing the 5 (tty) or F5 (video) keys when the IBM banner is shown.
>>I successfully booted a modified 'netinst' CD using those two methods on
>>the following IBM Power5 server: 9110-51A
>>Now, the kernel would not boot and the system went to Open Firmware. But
>>that issue is unrelated and something I will address next. It could be as
>>simple as me selecting the wrong image.
>Hi Rolf,
>Thanks for looking into this. 3.1r5 (aka Sarge r5) is the last stable
>release of Debian, using installation code and setup from 2005. We're
>probably not going to make any more changes to it at this point, as
>we're very close to releasing our new stable version (4.0 aka Etch).
>That should hopefully be more useful for you. Checking, your change to
>yaboot.conf is already merged in in the latest Etch test images, and
>we have a /ppc/bootinfo.txt file with similar information to yours and
>an icon.
>Could you try (for example) the image at
>and see how that works for you please? We'd love some good feedback at
>this point. :-)
>Steve McIntyre, Cambridge, UK. steve@einval.com
>"We're the technical experts. We were hired so that management could
>ignore our recommendations and tell us how to do our jobs." -- Mike Andrews
>#### signature.asc has been removed from this note on March 30, 2007 by Rolf Brudeseth


I tested the netinst CD you point to above, and have the following observations:

- Boot from SMS menus worked fine.

- The first time I tried to install the OS I selected 'install64'. However, it just took me back to the yaboot prompt. But this is not something I was able to reproduce later. On subsequent attempts it initiated the install procedure when I selected 'install64'.

- I successfully installed the OS using 'expert64'.

- When the system rebooted, the boot order was not updated. Technically this is not an error.
When AIX and SuSE is installed, the installer will update the boot order in SMS menus/Open Firmware such
that the device being installed to will automatically become the first boot device. Red Hat does not
support this. In my opinion, this is a feature that is very convenient.

- When the system rebooted and tried to install from the disk I got the following error:

Elapsed time since release of system processors: 1578 mins 56 secs

/pci@800000020000002/pci@2,4/pci1069,b166@1/scsi@1/sd@5,0:-1,/etc/yaboot.conf: Unknown or corrupt filesystem
Can't open config file
Welcome to yaboot version 1.3.13
Enter "help" to get some basic usage information
boot: help

Press the tab key for a list of defined images.
The label marked with a "*" is is the default image, press <return> to boot it.

To boot any other label simply type its name and press <return>.

To boot a kernel image which is not defined in the yaboot configuration
file, enter the kernel image name as [[device:][partno],]/path, where
"device:" is the OpenFirmware device path to the disk the image
resides on, and "partno" is the partition number the image resides on.
Note that the comma (,) is only required if you specify an OpenFirmware
device, if you only specify a filename you should not start it with a ","

If you omit "device:" and "partno" yaboot will use the values of
"device=" and "partition=" in yaboot.conf, right now those are set to:


Reply to: