[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#415343: installation-report: GRUB Error 15 at first boot.

On Sun, Mar 18, 2007 at 01:40:50PM -0300, Fabio Pugliese Ornellas wrote:
So, I used LVM for the root filesystem. At the first boot, GRUB gave me an Error 15. I checked out the documentation, and it says that it can not find a file (but it does not tell what file). I tryed rebooting with the Installation media and at the second virtual console, I managed to mount my root LVM and /boot, chroot into it, run GRUB manually to re-install it:

grub> root (hd1,0)
grub> setup (hd0)

No errors, but the same Error 15 at start up.

I tryed a GParted LiveCD, and from inside there, I called GRUB Shell and made a different configuration:

grub> root (hd1,0)
grub> setup --prefix=/grub (hd0)

In theory, should not change a thing, but... It worked!

I think error 15 means it can't find one of the files specified for the specific entry in /boot/grub/menu.lst (i.e. it can't find the kernel or initrd, not that it can't find any grub-specific files).

Interestingly enough, I get the same error when experimenting with the persistent device naming patch, and there the problem is that the /boot/grub/menu.lst file is created with entries like "kernel /boot/vmlinuz-<kvers>" and "initrd /boot/initrd.img-<kvers>".

Changing them at first boot to "kernel /vmlinuz-<kvers>" and "initrd /initrd.img-<kvers>" is enough to boot.

Could you please verify whether this is the case for you as well?

David Härdeman

Reply to: