[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Partitioner sets wrong type for RAID partitions?

> From: Steve Langasek [mailto:vorlon@debian.org] 
> Sent: Saturday, March 10, 2007 11:17 AM
> To: Zrin Ziborski
> Cc: debian-boot@lists.debian.org
> Subject: Re: Partitioner sets wrong type for RAID partitions?
> On Sat, Mar 10, 2007 at 10:52:06AM +0100, Zrin Ziborski wrote:
> > Yesterday (2007-03-09), I tried
> > 
> http://cdimage.debian.org/cdimage/daily-builds/daily/arch-late
> > /debian-testing-i386-netinst.iso for installation on an 
> older i686 (Celeron)
> > box.
> > After creating RAID partitions, the partitioner showed the
> > "Configure Software RAID" option, but the RAID configurator
> > complained about no available RAID partitions.
> > I tried zeroing the the first couple MiBs of the disks
> > and clearing superblocks without success.
> It's expected that you configure the individual partitions 
> for software RAID
> first, before choosing the 'Configure Software RAID' option.

Sorry if I did not express myself clear enough -

I did create individual _RAID_ partitions with the partitioner,
and those were shown as RAID in the list.
However, the "SW RAID configurator" complained about "no
available partitions".
Inspection with fdisk revealed type 83h!

Using fdisk I've changed prtition types to fdh.
After that I could use the D-I "SW RAID configurator" in
the usual way.

I've repeated the whole process once again after zeroing first
few MiB of both disks, i.e. partition table and the start of
the first partition
(e.g. dd if=/dev/zero of=/dev/hda bs=1024 count=4096)
- the results were the same.


Reply to: